mLab upgrading to MongoDB 3.0. My app is at Meteor 1.1. Should I be worried?

  • mLab is upgrading databases to MongoDB 3.0 shortly.
  • My app on Heroku is still at Meteor v1.1.0.2 (for various reasons).

I’m wondering if I should be anticipating some kind of incompatibility and therefore any outages.

Anybody know anything about these things? Should I be updating drivers in anticipation (and how would I even go about doing that on Heroku)? Something else?

Any help or advice is appreciated. Thx.

We plan on deploying soon and were considering Galaxy + mLab - I’m currently running 1.3. I would like to know this as well - would a 1.4 upgrade be necessary?

I’m in the same situation. I heard 1.3 works with 3.0, but the drivers might not be 100% compatible? And if we update to 1.4.1 then should we just also migrate to wired tiger while we are at it?

Meteor uses version 1.4.32 of the Node driver which is 3.0-compatible per the MongoDB docs:

You can confirm the underlying Node driver version yourself by checking meteor-package-dir/packages/mongo/package.js on line 16.

I would assume that subsequent versions of Meteor are safe.

BTW- we’re seeing some users report issues with the Meteor driver so I would caution against upgrading to this version for now. Specifically, there’s connection leaking on arbiter nodes- might be a regression in one of the newer versions of the underlying Node driver.

Y’all can also email us at if you have any questions specific to your deployment.

1 Like

Others say you have to be on 1.3 in order to have support. So much conflicting information. :cry:

Im not sure if your having any specific issues, but none of my projects had any “major” issues upgrading from 1.1 to 1.3.

Upgrading beyond that I’m a bit worried for the changes. But up to 1.3, the backwards compatibility support is currently good enough that there should not be too many breaking issues for most apps. It might be best to upgrade if possible?

Regarding my own situation, I’m on 1.3 and not sure if 1.4 will be necessary. Still waiting for a solid response here…

What are the reasons they give for requiring 1.3?

Are you wondering if 1.4 is required to be compatible with MongoDB 3.0? It is not.

I migrated the data to a Mongo3.0 DB and pointed my Staging app to it. It worked just fine. So @chrisckchang was right… the driver is supported in Meteor 1.1.

Big sigh of relief so far, but we’ll see how my Production DB fares. Plan B is to move data over to a Compose DB server (which can still be Mongo v2.6 if needed).

Will keep you posted…

1 Like

I’m on and I upgrade a few weeks back to Mongo 3.0 on mLabs. Everything works great so far. I don’t think we can update to 3.2 without issues unless we move to Meteor 1.4.1.

Where do you find out what version of the Node driver each Meteor version uses? thanks.


You can find it here:

Thanks. I actually also would like to know for a particular version of Meteor, which Node driver it is using. For example, which node driver does Meteor 1.3.2 use?

I did find a round about way to figure that out through steps listed here…

by running MongoInternals.NpmModules.mongodb.version from meteor shell.

But I wasn’t able to find that information in documentation, like meteor releases, guide, etc.

I have never seen that directory, so I’m not sure I can check meteor-package-dir/packages/mongo/package.js.

Personally I’m going on faith that all the compatibility info listed, from both MGD and Mongo, are correct.

Hey folks.
Just a follow-up, as promised…

The change was made by mLab and the app barely hiccuped. So all’s well on this front.

Thanks for all your input, and sorry if I caused anyone else any undo stress.

p.s. Go MDG!

@crsssl, what version of Meteor are you on, what version of Mongo did mLab bump you to?

We’re at Meteor right now, but planning an upgrade to Meteor 1.2.1 real soon, and probably Meteor 1.3.5 soon after that. (Don’t want to be going through this again for awhile.)

mLab bumped us up to mongod v3.0.12 (MMAPv1). With Meteor at, I can only assume the driver included in our Meteor bundle is at v1.4.29 or higher.