(Mobile) - mobile-config name breaks project


#1

Hi.

I’m about to deploy my app, while configuring stuff such as splash/icons and App info i wanted to add the name of the app which is suppose to show underneath the app-icon on your phone. When i add the “name” prefix, it breaks the whole project and wont let me run the ios-device command.

Adding id, description and such works just fine.

Any clues?


#2

Some code might be helpful in determining the cause.


#3

Yeah, sorry about that.

App.info({
id: ‘xxx.xxx.xxx’,
name: ‘thisbreaks’,
description: ‘A desceiption i wrote about the app’,
author: ‘Linus j’,
email: ‘Xxx@xxx.com’,
website: ‘http://xxxx.com
});

Written from my phone


#4

Shamelessly bumping this one since it’s still not working and it’s such a trivial problem :frowning:


#5

Yeah, I don’t see any glaring issues here, sorry.


#6

Neither do I :frowning: i’ve tried removing/adding the platform and gone into the config.xml as well but nothing seems to work.


#7

Have you tried running with the --verbose flag? That might help in diagnosing the issue.

Not sure if this is related, but in working on the improvements for the 1.2 release I’ve come across a bug in Cordova that seems to be triggered by renaming a project to a version with a different case on a case insensitive filesystem like OS X.


#8

Sadly verbose gives me nothing. All i know is that it says that my “xcode project cannot be opened because the project file cannot be parsed”


#9

Is there a way to clean the cordova build? I’ve tried removing/reinstalling both android/ios platform


#10

Yes, you can rm -rf .meteor/local/cordova-build from your Meteor project directory.


#11

Alright, thx! I’ll give this a try tomorrow morning :slight_smile:


#12

Will this possibly break the project?


#13

No, the project will be rebuilt when you run.


#14

Yeah, that’s what i thought. However when i rebuilt the project i was prompted with “this is not a cordova-based project.”


#15

Have you tried running with --verbose? Any more output that would help diagnose this?

What happens when you remove name from App.info?


#16

Yep, same was returned.
Removed the name prefix from the start.
(Pasted from mobile - i apologize for the messy log.)

After running ios --verbose:

% Running build for platforms: [ ‘ios’ ]
Running command /usr/bin/xcrun cc --version
% Building the cordova build project
% Bundling the web.cordova program of the app
% Ensuring the cordova build project
% Reading the mobile control file
% Running the mobile control file
% Copying resources for mobile apps
% Writing new config.xml
% Ensuring that platforms in cordova build project are in sync
Using (built-in) Android SDK at /Users/linus/.meteor/android_bundle/android-sdk
% Running synchronously: /Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/cordova-scripts/cordova.sh [ ‘platform’, ‘list’ ]
Error while running for mobile platforms: Error running
/Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/cordova-scripts/cordova.sh
Current working directory is not a Cordova-based project.

Error: Error running /Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/cordova-scripts/cordova.sh
Current working directory is not a Cordova-based project.

at execFileSyncOrThrow (/Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/commands-cordova.js:272:11)
at ensureCordovaPlatforms (/Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/commands-cordova.js:405:23)
at /Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/commands-cordova.js:796:5
at /Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/buildmessage.js:327:18
at [object Object]._.extend.withValue (/Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/fiber-helpers.js:115:14)
at /Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/buildmessage.js:326:36
at [object Object]._.extend.withValue (/Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/fiber-helpers.js:115:14)
at Object.enterJob (/Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/buildmessage.js:317:26)
at buildCordova (/Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/commands-cordova.js:769:16)
at Object.cordova.buildTargets (/Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/commands-cordova.js:137:3)
at Command.doRunCommand [as func] (/Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/commands.js:324:15)
at /Users/linus/.meteor/packages/meteor-tool/.1.1.4.2l3p0l++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/main.js:1363:23

#17

I’m not sure what could be going on here. The output doesn’t provide any clues to me.

If at all possible, I’d advise you to wait just a little longer for the public release candidate of Meteor 1.2, which includes an updated version of the Cordova integration that hopefully fixes these issues. If you still run into trouble then, at least the error reporting should be better and I might be able to help you.


#18

That makes two of us :confused:

Sadly, i lack the luxury to wait due to it being a production app (school project).

Hopefully someone else has had similar problems! I appreciate your time tho. :slight_smile:


#19

Ok! Solved :slight_smile:

1: Meteor Reset
2. Remove android/ios platforms
3. Reinstall platforms
4. Set “name” in mobile-config
5. Run on selected device ans wait for it to download cordova plugins
6. Launch

So it looks like the problem lies within cordova. The app name gets initiated the first time you run the app on your device and can’t be overwritten.
Not sure if this is the actual case but it seems like it.

Thank you very much for your help :slight_smile: