MonboDB Exited with code null - can I fix this somehow?

Just suddenly saw this today when I started my meteor dev environment. Tried a few things I found online, but finally had to do meteor reset which fixed it, but also wiped the db.

I’m just wondering what would have caused this.

I run on a Mac running MacOS Mojave.

been working perfectly fine til this morning.

It’s not horribly awful to have to start over and re-seed some data, but it’s pretty time consuming. Also makes me worry that something is wrong that would come up in production.

I usually work with a locally installed mongodb that was installed according to mongodb’s own documentation. Not this will at least prevent losing data when you do a Meteor reset.

About the error message. There can be many reasons for this error. Any action you did that might have triggered it? Did you run any intensive tasks or queries?

Not that I’m aware of as far as intensive tasks or queries, my data wasn’t overly large to start with beyond some address data I had imported, but I only queried for 20 at a time through my publication, and hadn’t done that all day.

As for using a fully installed MongoDB with meteor in development, how are you connecting to it? When I start meteor, it just starts and connects to the included mongo instance.