Mongodb exit code 1 while using meteor


#1

Hello everyone,
i just finished to installed my all new debian wheezy distribution. I would like to install meteor framework so i did sudo curl https://install.meteor.com/ | sh as recommended by the official meteor website

This framework uses node.js, mongodb and html ,but during the
installation i get this error when i type meteor after creating a new
meteor project.

=> Started proxy.

Unexpected mongo exit code 1. Restarting.

Unexpected mongo exit code 1. Restarting.

Unexpected mongo exit code 1. Restarting.

Can’t start Mongo server.

MongoDB failed global initialization

Looks like MongoDB doesn’t understand your locale settings. See
https://github.com/meteor/meteor/issues/4019 for more details

In fact, once a new project is created and operational after coding, the meteor command run a localhost web server on port 3000 and then we can see the web application.
I don’t understand why i get this error. Is it possible that’s my problem’s are coming from my debian distribution ?
I already check the link at the end of the error message and the problem resolved itself after 6 hours, i didn’t for me.

Thanks for help


#2

Anybody have an idea ?


#3

What do you get if you run the locale command at the shell prompt?


#4

Thanks for your response.
The locale command gave me this

[quote]LANG=fr_FR.UTF-8
LANGUAGE=
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
[/quote]


#5

And do you have the fr_FR locale installed?

ls /usr/share/i18n/locales/fr_FR

#6

Yes, it is,


Codenvy installation (only effective cloud IDE for meteor on free tier)
#7

Can you try

locale-gen fr_FR.UTF-8
localedef -i fr_FR -f UTF-8 fr_FR.UTF-8

#8

The commands works but didn’t solved the errors. The errors occurred when meteor selecting packages, do you it can be related ?


#9

So, I’m wondering whether MongoDB just can’t handle that locale. I guess you could try:

export LC_ALL="en_US.UTF-8"

If you don’t have that locale available you will need to build it:

locale-gen en_US.UTF8
localedef -i en_US -f UTF-8 en_US.UTF-8

#10

Can you try a ls .meteor/local/db from your project’s folder? I want to see if you’re missing local.ns


#11

It worked robfallows ! Thanks a lot, i can now start any meteor project.
Thank you for your help and to tannis too.
Have a nice day both of you.


#12

Thanks, resolved.
Same problem with en_GB.utf8,


#13

I’m currently seeing this issue in a docker container created from a ubuntu:16.04 image. I resolved it like this in my Dockerfile:

FROM ubuntu:16.04
ENV OS_LOCALE="en_US.UTF-8"
RUN locale-gen ${OS_LOCALE}
ENV LANG=${OS_LOCALE}
LANGUAGE=en_US:en
LC_ALL=${OS_LOCALE}
RUN apt-get update && apt-get -y install curl locales && curl https://install.meteor.com/ | sh


#14

Perfect! Thanks for the resolution. I think the OS_LOCALE should be defined in all docker files to avoid facing such issues.