Mongodump cannot find openssl version on macOS Catalina

Hi there. So I upgraded to macOS Catalina (kinda dumb of me), and also did a recent brew update && brew upgrade, and now I get the following error whenever trying to do a mongodump:

dyld: Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib
  Referenced from: /usr/local/bin/mongodump
  Reason: image not found
./dumpDB.sh: line 3: 68528 Abort trap: 6           mongodump --out /Users/user_name_here/Desktop/Meteor -h localhost --port 3001

I’ve tried doing brew reinstall openssl, installing community version of mongodb via brew (which I figured wouldn’t do anything), updating Meteor to 1.8.2, echo 'export PATH="/usr/local/opt/openssl@1.1/bin:$PATH"' >> ~/.zshrc, and I’m at a loss here. Any ideas?

Just encountered this issue as well. Will let you know if I figure out a solution.

Found a solution! https://github.com/EOSIO/eos/issues/8235#issuecomment-558995934

Homebrew changed its version of Openssl to 1.1 days ago (Homebrew/homebrew-core@0349a7c and Homebrew/homebrew-core@b4b9c1c).
We can downgrade Openssl to the older version to temporarily fix this issue while waiting for the new rebuild to come (or do it manually):

Running this solved it for me:

brew uninstall --ignore-dependencies openssl
brew install https://raw.githubusercontent.com/Homebrew/homebrew-core/30fd2b68feb458656c2da2b91e577960b11c42f4/Formula/openssl.rb