MUP Deploy Failed

sudo mup setup works (using node version 0.10.40), but fails on sudo mup deploy.
After attempting a deploy, I get this error message:

[MyIpAddress] x Invoking deployment process: FAILED

npm WARN package.json meteor-dev-bundle@0.0.0 No description
npm WARN package.json meteor-dev-bundle@0.0.0 No repository field.
npm WARN package.json meteor-dev-bundle@0.0.0 No README data
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed 0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (7) Failed to connect to localhost port 32888: Connection refused
Latest deployment failed! Reverted back to the previous version.
> node ./build.js

`linux-x64-v8-3.14` exists; testing
Binary is fine; exiting
ansi-regex@0.2.1 node_modules/ansi-regex

ansi-styles@1.1.0 node_modules/ansi-styles

chalk@0.5.1 node_modules/chalk

escape-string-regexp@1.0.3 node_modules/escape-string-regexp

supports-color@0.2.0 node_modules/supports-color

strip-ansi@0.3.0 node_modules/strip-ansi

has-ansi@0.1.0 node_modules/has-ansi

eachline@2.3.3 node_modules/eachline

type-of@2.0.1 node_modules/type-of

amdefine@1.0.0 node_modules/amdefine

asap@2.0.3 node_modules/asap

underscore@1.5.2 node_modules/underscore

meteor-promise@0.5.0 node_modules/meteor-promise

promise@7.0.4 node_modules/promise

source-map-support@0.3.2 node_modules/source-map-support

semver@4.1.0 node_modules/semver

source-map@0.1.32 node_modules/source-map

fibers@1.0.5 node_modules/fibers
Waiting for MongoDB to initialize. (5 minutes)
Waiting for 150 seconds while app is booting up
Checking is app booted or not?
 // Server authentication info
"servers": [
      "host": "MyIPAddress",
      "username": "root",
      "password": "MyPassWord"
      // or pem file (ssh based authentication)
      //"pem": "~/.ssh/id_rsa"

  // Install MongoDB in the server, does not destroy local MongoDB on future setup
  "setupMongo": false,

  // WARNING: Node.js is required! Only skip if you already have Node.js installed on server.
  "setupNode": true,

  // WARNING: If nodeVersion omitted will setup 0.10.36 by default. Do not use v, only     version number.
  "nodeVersion": "0.10.40",

  // Install PhantomJS in the server
  "setupPhantom": true,

  // Show a progress bar during the upload of the bundle to the server. 
  // Might cause an error in some rare cases if set to true, for instance in Shippable CI
  "enableUploadProgressBar": true,

  // Application name (No spaces)
  "appName": "myAppName",

  // Location of app (local directory)
  "app": "../myAppName",

  // Configure environment
  "env": {
    "PORT": 32888,
    "ROOT_URL": "http://MyIPAddress"

  // Meteor Up checks if the app comes online just after the deployment
  // before mup checks that, it will wait for no. of seconds configured below
  "deployCheckWaitTime": 150

mup log -f` gives me this

cannot open ‘/var/log/upstart/MyMeteorAppName.log’ for reading[MyIPAddress] : No such file or directory[MyIPAddress]`

Unfortunately, my VM doesn’t support docker so I cannot use mupx.

What linux distro is your VM running?

Hi @hwillson, The VM is Ubuntu 14.04 LTS and the server is Ubuntu 15.04

Does the /var/log/upstart directory exist on your server? If not try creating it via sudo mkdir /var/log/upstart and redeploy.

I was having trouble deploying with mup too. I had to set up a fresh server with Ubuntu, and use mupx, instead of mup. Then it worked.

Hi @hwillson. I’ve tried sudo mkdir /var/log/upstart but I got this response:
mkdir: cannot create directory ‘/var/log/upstart’: File exists

I’m trying to do a touch MyAppName.log inside that upstart folder. Crossing fingers…

Hey @razataz. I can’t use mupx because my VM doesn’t support docker :frowning:

I recommend setting up a new server up in AWS. They offer servers in the “free tier”. Make sure you setup the Ubuntu type of server.

Thanks @razataz, I successfully deployed my Meteor app on AWS using the steps described in this tutorial:

However, I wanted to leave these tips here in case anyone else had the same problems with mup:

  1. I went through the AWS/MUP tutorial steps and everything went well until mup setup and encountered an error:
    Installing PhantomJS: FAILED -----------------------------------STDERR----------------------------------- 404 Not Found [IP: 80] ..."
    To fix this, I had to run npm install -g node-gyp

  2. In the mup.json file, the “pem” field actually has to be the path to your FILE, not just the directory (I made that mistake). i.e. it has to be "pem" : "~/ssh/pemfilename.pem

  3. I also couldn’t install PhantomJS so I just set "setUpPhantom":false in my mup.json file. I also put "PORT":80 in the “env” object.

Otherwise, everything worked out great! Thanks for the advice.