Mup Deploy fails


#1

Hi!
I’m currently using meteor up to try and deploy to a digital ocean 16.04 ubuntu droplet. I’ve made my mup.js file and mup setup works but when I try to mup deploy, I get the below error. Changing the wait time (even to 1000) still does not fix this. Any idea where I could have an issue? Running the program locally works

[162.243.165.50] x Verifying Deployment: FAILED
	
	-----------------------------------STDERR-----------------------------------
	r app on port:80
	/bundle/bundle/programs/server/node_modules/fibers/future.js:280
							throw(ex);
							^
	
	ReferenceError: module is not defined
	    at app/mup.js:1:-27
	    at app/mup.js:68:4
	    at /bundle/bundle/programs/server/boot.js:338:34
	    at Array.forEach (native)
	    at Function._.each._.forEach (/bundle/bundle/programs/server/node_modules/underscore/underscore.js:79:11)
	    at /bundle/bundle/programs/server/boot.js:158:5
	    at /bundle/bundle/programs/server/boot.js:387:5
	    at Function.run (/bundle/bundle/programs/server/profile.js:510:12)
	    at /bundle/bundle/programs/server/boot.js:386:11
	
	> meteor-dev-bundle@0.0.0 install /bundle/bundle/programs/server
	> node npm-rebuild.js
	
	
	> bcrypt@1.0.2 install /bundle/bundle/programs/server/npm/node_modules/bcrypt
	> node-pre-gyp install --fallback-to-build
	
	[bcrypt] Success: "/bundle/bundle/programs/server/npm/node_modules/bcrypt/lib/binding/bcrypt_lib.node" is installed via remote
	 
	=> Redeploying previous version of the app
	 
	-----------------------------------STDOUT-----------------------------------
	
	To see more logs type 'mup logs --tail=100'
	
	----------------------------------------------------------------------------


For reference, this is the mup.js file

module.exports = {
  servers: {
    one: {
      // TODO: set host address, username, and authentication method
      host: 'XXX.XXX.XXX.XX', //ip address
      username: 'root',
       pem: '~/.ssh/id_rsa'
      // password: 'server-password'
      // or neither for authenticate from ssh-agent
    }
  },

  meteor: {
    // TODO: change app name and path
    name: 'app',
    path: '/Users/computer/Desktop/app',

    servers: {
      one: {},
    },

    buildOptions: {
      serverOnly: true,
    },

    env: {
      // TODO: Change to your app's url
      // If you are using ssl, it needs to start with https://
      ROOT_URL: 'http://XXX.XXX.XXX.XX',
      MONGO_URL: 'mongodb://localhost/meteor',
    },

    // ssl: { // (optional)
    //   // Enables let's encrypt (optional)
    //   autogenerate: {
    //     email: 'email.address@domain.com',
    //     // comma seperated list of domains
    //     domains: 'website.com,www.website.com'
    //   }
    // },

    docker: {
      // change to 'kadirahq/meteord' if your app is not using Meteor 1.4
      image: 'abernix/meteord:base',
      // imagePort: 80, // (default: 80, some images EXPOSE different ports)
    },

    // This is the maximum time in seconds it will wait
    // for your app to start
    // Add 30 seconds if the server has 512mb of ram
    // And 30 more if you have binary npm dependencies.
    deployCheckWaitTime: 1000,

    // Show progress bar while uploading bundle to server
    // You might need to disable it on CI servers
    enableUploadProgressBar: true
  },

  mongo: {
    port: 27017,
    version: '3.4.1',
    servers: {
      one: {}
    }
  }
};


#2

Don’t put your mup.js in the root of your Meteor application. Put it in a .deploy folder, as instructed in the setup instructions.