Mup deploy problem


#1

Hi, im trying to deploy a datebaseless app into a server, but i get:

[files.000webhost.com] - Pushing Meteor App Bundle to The Server
events.js:182
throw er; // Unhandled ‘error’ event
^

Error: Timed out while waiting for handshake
at Timeout._onTimeout (/usr/lib/node_modules/mup/node_modules/nodemiral/node_modules/ssh2/lib/client.js:138:17)
at ontimeout (timers.js:471:11)
at tryOnTimeout (timers.js:306:5)
at Timer.listOnTimeout (timers.js:266:5)

this is my mup.js file

module.exports = {
  servers: {
    one: {
      // TODO: set host address, username, and authentication method
      host: 'files.000webhost.com',
      username: 'acmyp',
      // pem:
      password: '.........'
      // or neither for authenticate from ssh-agent
    }
  },

  app: {
    // TODO: change app name and path
    name: 'acmyp',
    path: '../',

    servers: {
      one: {},
    },

    buildOptions: {
      serverOnly: true,
    },

    env: {
      // TODO: Change to your app's url
      // If you are using ssl, it needs to start with https://
      ROOT_URL: 'http://test.com',
      MONGO_URL: 'mongodb://localhost/meteor',
    },

    // ssl: { // (optional)
    //   // Enables let's encrypt (optional)
    //   autogenerate: {
    //     email: 'email.address@domain.com',
    //     // comma separated list of domains
    //     domains: 'website.com,www.website.com'
    //   }
    // },

    docker: {
      // change to 'abernix/meteord:base' if your app is using Meteor 1.4 - 1.5
      image: 'abernix/meteord:node-8.4.0-base',
    },

    // Show progress bar while uploading bundle to server
    // You might need to disable it on CI servers
    enableUploadProgressBar: true
  },

  mongo: {
    version: '3.4.1',
    servers: {
      one: {}
    }
  }
};

I can access via filezila with those settings, what can the problem be? is there other way to deploy?

Thank you


#2

I think mup connects via ssh protocol.
Is it listening at port 22?
Maybe you need to read the docs of your provider…
Try to connect via SSH to the server… having mup working the first time isn’t that simple… after that it’s GREAT!