MUP Deploy Stuck

I am trying to deploy my meteor project at AWS(EC2 instance type => t2.micro) using MUP. But somehow it always stucks when it comes to mup deploy=>Building for web.browser.legacy and every time I need to restart instance from aws console as it hangs.

I thought it may be the issue of space but result of df -h is

Filesystem      Size  Used Avail Use% Mounted on
udev            481M     0  481M   0% /dev
tmpfs            99M  840K   98M   1% /run
/dev/xvda1       30G  5.8G   24G  20% /
tmpfs           492M     0  492M   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           492M     0  492M   0% /sys/fs/cgroup
/dev/loop0       13M   13M     0 100% /snap/amazon-ssm-agent/495
/dev/loop1       18M   18M     0 100% /snap/amazon-ssm-agent/930
/dev/loop2       88M   88M     0 100% /snap/core/5742
/dev/loop3       17M   17M     0 100% /snap/amazon-ssm-agent/784
/dev/loop5       89M   89M     0 100% /snap/core/5897
/dev/loop4       90M   90M     0 100% /snap/core/6034
tmpfs            99M     0   99M   0% /run/user/1000

docker container mongodb is also running,

docker ps -a
CONTAINER ID        IMAGE               COMMAND                  
CREATED             STATUS              PORTS                        
51398378c446        mongo:3.6.3         "docker-entrypoint.s…"   42 
minutes ago      Up 2 minutes>27017/tcp   

AWS Ubuntu OS details-

Ubuntu 18.04.1 LTS (GNU/Linux 4.15.0-1029-aws x86_64)

Also tried to deploy brand new empty default meteor app but still no luck.

My mup.js file

module.exports = {
servers: {
one: {
  host: 'X.XX.XX.XXX',
  username: 'ubuntu',
  pem: '~/.ssh/pemfilename.pem'

 app: {
name: 'cool',
path: '~/meteor/my_cool_app',

servers: {
  one: {},

buildOptions: {
  serverOnly: true,

env: {
  ROOT_URL: '',
  MONGO_URL: 'mongodb://',
  PORT: 3003,

docker: {
  image: 'abernix/meteord:node-8.4.0-base',
enableUploadProgressBar: true,

mongo: {
servers: {
  one: {}

Meteor Version of my app,


also tried with by downgrading my new app, re-installed meteor many times, tried removing node_modules and installed again, no luck.

Sorry for such a long post but I want to provide as much as info possible. Thanks in advance.

I think that MUP support Ubuntu 16 only.


I used image: ‘zodern/meteor:root’, because abernix image doesn’t work.

1 Like

Possible, searched a little and got to know people are facing this kind of issue,

Feeling thankful, you showed me the direction. Atleast I can go ahead with previous versions of ubuntu.

Yes, you can.

I use MUP for testing environment, but to production, I install with Phusion Passenger and Nginx. This case, I can choose any linux distro and version.

Hey. i am also facing same issue but on Ubuntu 16.04. Could you please share how did this worked for you ? @rashmimhatre100 rashmimhatre100