MUP mongo version problem

I have a working project with meteor version, which I recently upgraded to 1.8.1 locally while updating some functionalities on the project.

When I tried to deploy with MUP, I foolishly changed the mongo version from 3.4.1 to 4.0.6 in my mup.js file. Now I am unable to deploy, and it shows the following when I run docker logs mongodb:

** IMPORTANT: UPGRADE PROBLEM: The data files need to be fully upgraded to version 3.6 before attempting an upgrade to 4.0; see for more details.

Is there a way to reverse this? More importantly, if I need to run the project on a new server, is there any way to recover the previous data?

Any help would be greatly appreciated, thank you.

can’t you simply change mongo version back to 3.4.1 and deploy again?

Or, if you want to upgrade mongo, upgrade in steps, doing an upgrade to version 3.6 first.

1 Like

Everything is back to normal now.

I reverted the version back to 3.4.1, which didn’t work. I then killed off all containers on the server, which did not work as well. I also killed off port 80 on the server, but still didn’t work.

In the end I found out it was also because I installed bcrypt due to the annoying warnings on meteor start, which led to meteor not starting up on the server for some reason.

After removing bcrypt, I was able to deploy successfully again, and my database was also intact.

Thanks a lot for the suggestions.


I vaguely remember having this issue with bcrypt as well, a year or so ago. Did cause me the same kind of trouble then.