Mupx: Archiving failed: ENOENT


#1

Anyone knows what is this error? After running mupx deploy, I get this:

=> Archiving failed: ENOENT: no such file or directory, stat '/tmp/85ef3626-6e60-4bde-8d08-e793215bfc22/bundle/programs/server/npm/react-runtime-prod/node_modules/react/node_modules/envify/node_modules/jstransform/node_modules/esprima-fb/.#README.md'

meteor build . finishes wihtout error.


#2

I have the same issue.

I resolved it reverting back react-runtime to version 0.14.3


#3

+1 I’m having the same issue


#4

+1, but with regular mup. Seems to have started with the upgrade of react-runtime to version 0.14.4. Going to try revert to 0.14.3.


#5

I’m having the same issue with react 0.14.4, reverting it (react, react-runtime, react-runtime-dev, react-runtime-prod) to 0.14.3 fixed the issue.

Has an issue for this been created on the github?


#6

+1, but with mup as well. How do you revert these packages back? My React is currently listed at 0.14.3


#7

I’d just add react-runtime@0.14.3 into .meteor/packages file


#8

I was still this problem even after reverting to 0.14.3. You have to make sure that in your .meteor/versions file the dependencies are also at 0.14.3.

react-runtime@0.14.3
react-runtime-dev@0.14.3
react-runtime-prod@0.14.3

Here’s a GitHub issue on the mup repo - https://github.com/arunoda/meteor-up/issues/812


#9

Thanks, that worked.

Had to use react-runtime@=0.14.3 to make sure it reverts and doesn’t update.


#10

Well this is a weird bug, but again, I too, am suffering from this issue.


#11

Am I missing something, because no matter what I seem to do, I can’t get my React packages to downgrade back to 0.14.3!?

I have react@0.14.3 in my .meteor/packages file, which I thought should do it…?


#12

Ah okay, for anyone else that’s having issues, I had to do the following:

  1. Remove the react bundler package from my meteor installation

  2. Add the following individual packages to my packages file:

jsx
react-meteor-data
react-runtime@=0.14.3
react-template-helper@=0.2.4
  1. Call meteor update and it will downgrade everything for you

#13

I’m also having this problem with mup (not mupx). Downgrading worked.


#14

perhaps some people releasing the React packages could jump in? @benjamn ; @sashko ; @evanyou ; …?


#15

Shame that the cause of this is still unknown; I’d really like to get the latest React packages onto my deployment :confused: @arunoda & @sashko what can we do to help?


#16

I gave up and went to Meteor Dev Edition. It worked.


#17

looks like a recent issue. Now I’m stuck with it.

@Siyfion’s tutorial worked great.


#18

Indeed. I was fortunate enough to get an invite so that’s what I did too.


#19

I’d love to hear from @arunoda or @sashko as to whether they are aware of this issue; whether it’s a MUP bug or a React Package bug!?


#21

Instead of downgrading react , the following change worked for me :

add the following to the archiveIt function in build.js file of your mup installation ("/usr/local/lib/node_modules/mup/lib/build.js" for me) …

var esprimaFolder = sourceDir+'/programs/server/npm/react-runtime-prod/node_modules/react/node_modules/envify/node_modules/jstransform/node_modules/esprima-fb/';
  if(fs.existsSync(esprimaFolder+'#README.md#')){
  	fs.renameSync(esprimaFolder+'#README.md#',esprimaFolder+'.#README.md');
}

The complete file highlighting where to add the code…gist