MUPX Configuration Error? Timed out while waiting for handshake?


After npm install -g mupx

$ mkdir .deploy
$ cd .deploy
$ mup init

Then inside .deploy/mup.json

  // Server authentication info
  "servers": [
      "host": "",   
      "username": "root",
//      "password": "password",
      // or pem file (ssh based authentication)
      // WARNING: Keys protected by a passphrase are not supported
      "pem": "~/.ssh/id_rsa",
      // Also, for non-standard ssh port use this
      "sshOptions": { "port" : 3012 }, //49154
      // server specific environment variables
      "env": {}

  // Install MongoDB on the server. Does not destroy the local MongoDB on future setups
  "setupMongo": true,

  // Application name (no spaces).
  "appName": "myapp",

  // Location of app (local directory). This can reference '~' as the users home directory.
  // i.e., "app": "~/Meteor/my-app",
  // This is the same as the line below.
  "app": "..",

  // Configure environment
  // ROOT_URL must be set to your correct domain (https or http)
  "env": {
    "PORT": 3012, //80
    "ROOT_URL": ""

  // Meteor Up checks if the app comes online just after the deployment.
  // Before mup checks that, it will wait for the number of seconds configured below.
  "deployCheckWaitTime": 600, //15

  // show a progress bar while uploading. 
  // Make it false when you deploy using a CI box.
  "enableUploadProgressBar": true

Started Vagrant Manager and SSH into one of the machines:

$ vagrant ssh
Welcome to Ubuntu 14.04.5 LTS (GNU/Linux 3.13.0-93-generic i686)

System information disabled due to load higher than 1.0

Get cloud support with Ubuntu Advantage Cloud Guest:

0 packages can be updated.
0 updates are security updates.

New release ‘16.04.1 LTS’ available.
Run ‘do-release-upgrade’ to upgrade to it.

The shared directory is located at /vagrant
To access your shared files: cd /vagrant
Last login: Sun Aug 28 20:54:20 2016 from
vagrant@vagrant-ubuntu-trusty-32:~$ uname


Local Mac OSX machine:

$ .deploy/mupx setup

Meteor Up: Production Quality Meteor Deployments

Configuration file : mup.json
Settings file : settings.json

“ Checkout Kadira!
It’s the best way to monitor performance of your app.

Started TaskList: Setup (linux)
[] - Installing Docker
throw er; // Unhandled ‘error’ event

Error: Timed out while waiting for handshake
at Timeout._onTimeout (/usr/local/lib/node_modules/mupx/node_modules/ssh2/lib/client.js:138:17)
at tryOnTimeout (timers.js:224:11)
at Timer.listOnTimeout (timers.js:198:5)

Also tried in new test project with meteor version and still the same issue.

This article

"app": "..",

whereas this video:


"app": E:/fullpath/to/app

Feedback on incorrect configuration would be appreciated. Thanks

Changing the public IP address for internal IP address, like 192.168.xx.xx, resolve the issue in my case, Meteor, Node 4.6.2, Debian Jessie.