Mupx deploy - my deployment hangs forever - why?

I’m trying to deploy with mupx. I rebuilt my digital ocean droplet from scratch as part of the process. Output from trying to deploy is in the screenshot. My question: why doesn’t my deploy work?

Do you see anything in the logs?

mupx logs -f

Nothing helpful. All I see is the following:

That’s a docker error so for some reason your mupx docker environment wasn’t setup properly. Have you tried running mupx setup again? Can you share your mup.json file?

I totally rebuilt the digital ocean droplet, then ran mupx setup again before running mupx deploy. Here is my mup.json:

Hmm, I again re-built my droplet from scratch and re-ran mupx setup and mupx deploy Again, it hangs forever.

What do you see when you run docker ps on your server?

I see this

Bizarre - do you see anything extra when you run:

DEBUG=* mupx deploy

I see this

I am using fresh Ubuntu 14.04.4 x64 droplets on digital ocean.

How can I tell whether mupx setup worked correctly before I try mupx deploy ?


Ok, so instead of just completely rebuilding my droplet, I destroyed it and created a new droplet with a different IP. Now things seem to be working again. I don’t understand what the problem was, of course.

I hate when that works, I always want to know what’s gone wrong.

I was also curious to see how this was resolved. Ran into something similar with mupx on do and ended up just using mup instead.

Hmm, well my problems came back. I just tried deploying again, this time to the new IP droplet from before, and mupx deploy crashed.

I got the same error when I tried mupx stop or mupx restart, etc.

I proceeded to re-build the droplet through the digital ocean admin panel, then I ran mupx setup and mupx deploy again and this time it worked.

Ouch - definitely a tricky one to troubleshoot then. You could always try opening an issue, but at 457 open mup/mupx issues and counting, that might not help much. Another option is to start debugging the mupx code yourself, to see where it’s failing specifically. The codebase is actually quite small and pretty easy to work with (and I’m sure they’d love PR’s).

On a related note - Galaxy Developer Edition is now open for all! Welcome back meteor deploy :slightly_smiling:

I think it basically comes down to the fact that my app is too RAM or CPU intensive for the droplet.