Mupx deploy to Ec2 , verifying deploy fail. Please Help me


#1

yesterday I use Mupx to deploy new project to Ec2 and completely failed .

  1. connect to Ec2 success,

  2. set http port 80 ,ssh port 22 done;

  3. mupx setup , done;

4), mupx deploy ,last step , verifying deploy failed .

on matter i set time is over 600. I have tried to use Node different version 0.10.40 .44 V4.4.7 V4.8 , still failed. also tried to add dockImage to Mup.json. I uninstall Meteor Node and install them again , still failed. I have googled many information , no solution. Can you please tell me how to resole this problem.
image


#2

mupx isn’t maintained anymore. The last version with which it worked consistently for me was Meteor 1.2.1. I’ve left some apps on that version deliberately because mupx was/is a convenient deployment strategy.


#3

You mean , I should downgrade Meteor to 1.2 instead of 1.4


#4

If you want to be able to deploy with mupx, yes.

There is a newer (maintained) version of mup at: https://github.com/kadirahq/meteor-up


#5

Thanks Babrahams, i will try it soon .


#6

Babarhams:
my dear,
I have solved this issue,
thank you very much
you are my angel today
thanks again and again


#7

Hi there. i’m facing the same problem. could I ask how you solved this issue?


#8

Hi,
the problems is we have deployed too many times with different mup versions in this folder.
1)create a new Meteor project , and copy your all codes except meteor packages and npm .
2) manually add meteor packages and npm install packages you need
3) npm install -g mup
4) mup init
5) config mup.js // add dockerImg
6) connect Ec2 via SSH
7) mup setup
8) mup deploy


#9

Thank you for that. What do you mean by “add dockerimg”? how do i go about adding it?