Mupx deployment issues

This is really strange. I’m using mupx to deploy, and I get these errors:

Error: failed to connect to [xxx:NaN]
    at Object.Future.wait (/bundle/bundle/programs/server/node_modules/fibers/future.js:398:15)
    at new MongoConnection (packages/mongo/mongo_driver.js:213:27)
    at new MongoInternals.RemoteCollectionDriver (packages/mongo/remote_collection_driver.js:4:16)
    at Object.<anonymous> (packages/mongo/remote_collection_driver.js:38:10)
    at Object.defaultRemoteCollectionDriver (packages/underscore/underscore.js:750:1)
    at new Mongo.Collection (packages/mongo/collection.js:102:40)
    at AccountsServer.AccountsCommon (packages/accounts-base/accounts_common.js:23:18)

Anyone else having issues with this? The credentials are correct. The NaN above seems fishy though, so I don’t know if it’s a mupx problem or not.

Check that you haven’t got a space at the end of the URL or something?
It looks like the port is NaN…

edit: I don’t use 1.3, but I use MongoLabs and I’ve never had an issue.

The MONGO_URL in mup.json seems fine:

  "env": {
    "PORT": 3000,
    "ROOT_URL": "",
    "MONGO_URL": "mongodb://"

Upon further investigation (using netstat), I don’t even see it attempt to connect to any IP on port 47065.

I also ruled out 1.3, by deploying a really simple 1.2 app that just inserts a document into the DB. Same problem.

Retitling the thread as it appears to be a mupx issue. @arunoda, did something change? This looks fishy in the errors:

Error: failed to connect to []

Like the port number in the MONGO_URL is not coming through properly.

If you’re able to get your simple test app up and running, maybe try dumping MONGO_URL so you can see how the app see’s it:

if (Meteor.isServer) {

Might help with troubleshooting.

I hope development and bugfixes on mupx doesn’t stall due to Galaxy being out. Plenty of people still want to launch on their own VPSs.

I’ll give your suggestion a shot, thanks!

Actually, @arunoda and his team have hinted that a new version of Mup is coming in February, based on mupx. Can’t wait to see it! (see the first paragraph of Testing Meteor Up — It’s Harder Than We Thought for the hint).

1 Like

mupx works bro it just seems the server you are deploying to has no open ports or something!

are you sure the port 80 is open?

did enable ufw? the firewall?

I had this issue with Rackspace then I enabled ufw and allowed the ports 80 …

Trust me, bro, it’s not working! :wink: The NaN in the error log is a big clue that something is not right. All ports necessary are open.

well NaN means the ports is undefined

try to use local db to see if the problem persists then go back to your external mongodb and see?

Debugging bro :stuck_out_tongue:

They are working with a new mup which is kadirahq/meteor-up… but It’s still in the works