Mupx setup error log sudo: docker: command not found


#1
root@abc-desktop:~/Myproject# mupx setup

Meteor Up: Production Quality Meteor Deployments

Configuration file : mup.json
Settings file : settings.json

“ Checkout Kadira!
It’s the best way to monitor performance of your app.
Visit: https://kadira.io/mup

Started TaskList: Setup (linux)
[64.62.206.242] - Installing Docker
[64.62.206.242] x Installing Docker: FAILED

-----------------------------------STDERR-----------------------------------
bash: line 4: docker: command not found
rm: cannot remove ‘/var/cache/apt/archives/lock’: No such file or directory
+ sh -c apt-key adv --keyserver hkp://p80.pool.sks-keyservers.net:80 --recv-keys 58118E89F3A912897C070ADBF76221572C52609D
gpg: requesting key 2C52609D from hkp server p80.pool.sks-keyservers.net
gpg: key 2C52609D: "Docker Release Tool (releasedocker) <docker@docker.com>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
+ sh -c mkdir -p /etc/apt/sources.list.d
+ sh -c echo deb https://apt.dockerproject.org/repo ubuntu-trusty main > /etc/apt/sources.list.d/docker.list
+ sh -c sleep 3; apt-get update; apt-get install -y -q docker-engine
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
-----------------------------------STDOUT-----------------------------------
.ubuntu.com trusty-backports/universe i386 Packages
Hit http://us.archive.ubuntu.com trusty-backports/multiverse i386 Packages
Hit http://us.archive.ubuntu.com trusty-backports/main Translation-en
Hit http://us.archive.ubuntu.com trusty-backports/multiverse Translation-en
Hit http://us.archive.ubuntu.com trusty-backports/restricted Translation-en
Hit http://us.archive.ubuntu.com trusty-backports/universe Translation-en
Ign http://us.archive.ubuntu.com trusty/main Translation-en_US
Ign http://us.archive.ubuntu.com trusty/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com trusty/restricted Translation-en_US
Ign http://us.archive.ubuntu.com trusty/universe Translation-en_US
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 nginx-core : Depends: nginx-common (= 1.4.6-1ubuntu3.3) but it is not going to be installed
----------------------------------------------------------------------------

mup.json file

{
// Server authentication info
"servers": [
{
“host”: “myhost”,
“username”: “root”,
“password”: “password”,
// or pem file (ssh based authentication)
// WARNING: Keys protected by a passphrase are not supported
//“pem”: “~/.ssh/id_rsa”,
// Also, for non-standard ssh port use this
"sshOptions": { “port” : 7576 },
// server specific environment variables
"env": {}
}
],

// Install MongoDB on the server. Does not destroy the local MongoDB on future setups
"setupMongo": true,

// Application name (no spaces).
“appName”: “myproject”,

// Location of app (local directory). This can reference ‘~’ as the users home directory.
// i.e., “app”: “~/Meteor/my-app”,
// This is the same as the line below.
“app”: “/home/abcd/myproject”,

// Configure environment
// ROOT_URL must be set to your correct domain (https or http)
“env”: {
“PORT”: 80,
“ROOT_URL”: “http://mysite.com/
},

// Meteor Up checks if the app comes online just after the deployment.
// Before mup checks that, it will wait for the number of seconds configured below.
“deployCheckWaitTime”: 120,

// show a progress bar while uploading.
// Make it false when you deploy using a CI box.
“enableUploadProgressBar”: true
}

what is wrong in mup.json

deploying on Ubuntu 14.04.3 LTS


#2

I’m having the same problem. Any luck fixing this?


#3

I’m having the same issue


#4

Still problem. Any luck?


#5

I had a similar issue yesterday on Digital Ocean server. The only difference was that the mupx script hanged up at “installing Docker” no error message. My solution was to stop/restart the sever, then deploy again :confused: Hope it helps


#6

anyone get the solution… ??


#7

I have the same problem.

I solved it installing docker on server.

Exemplary instruction of instataion docker on Ubuntu 15:

https://www.liquidweb.com/kb/how-to-install-docker-on-ubuntu-15-04/


#8

Use the new Meteor Up: https://github.com/zodern/meteor-up/

Mupx issues can be reported here: https://github.com/zodern/meteor-up/issues/


#9

Installing docker is worked for me. Thanks @gustawdaniel