My Android App keeps pointing to the 'production' server


#1

Hi, pretty new to meteor and moving the first steps towards deploying meteor apps to mobile devices.

Here my case:

I deployed my metor app on meteor.com servers ( xxx.meteor.com)

Some weeks ago i deployed the app in my android phone, i don’t rember the command i used but probably was

meteor run android-device --mobile-server xxx.meteor.com

And everything worked fine.

Now i have a new version of my app (running on my local computer) and i want to deploy it on my mobile device for testing purposes:

  • I uninstalled the previous version on my mobile
  • I issued the command meteor run android-device -p 192.168.1.6:3000

My app starts but it keeps pointing to the xxx.meteor.com server, showing me the old-production version of my code.

What am i missing here?

Thanks for any help!


#2

This is indeed a weird behavior, and I can see only a couple of ways this could happen:

  • You have some cache from an old app pointed to the prod server. To delete it, either remove the app from the phone completely, or go to settings and clear its app data.
  • You have some sort of appcache installed on your app. Clean app cache?

#3

Oh yes!

I went in Settings->Apps->MyApp and before uninstall i cleaned the cache up, it worked!

Thanks a lot!