New to Digital Ocean and server deployment. How do I debug things?

I’m trying to deploy my app to a Digital Ocean droplet. It deployed (eventually), but I’m getting strange bugs that I never got on localhost. I’m very new to this so I’m not even sure how to debug these things properly.

How do I look at the server side logs if I do a console.log? Any general tips or general resources for a server deployment noob?

More info on my deployment issues:
I think it has to do with NPM. I’m using browserify and npm, getting some issues with it too.

Could you be more specific about what kind of things you want to debug ?

There are lot of things , and depends how are you deploying ( mup , pm2 , just build from meteor command line, using ngnix of not…

I’m glad to help you, but you have to give us a clue :wink:

To give some more details:

  • Using mup to deploy to Digital Ocean droplet (Ubuntu 14.04.3 x64)
  • I’d like to view the output of my server side console logs somewhere

Just type on your server console (ssh) :

mup logs -f

This is already documented and @arunoda is doing a great job documenting and explaining all the things he does:

Cheers mate,

are you sure it should be typed on server console?
with mupx it is on deployment machine

1 Like

Hmm I ssh’d into my droplet server, tried typing mup into it. Didn’t seem to work. I did mup logs -f from my development machine and it seems to work. Thanks!

Indeed , you’re right , Sorry for the mistake.

I had the same question, but when I run mup logs -f, I get:

[] at [object Object].filterFunction (packages/meteorhacks_fast-render/lib/server/routes.js:6:1) at [object Object].PickerImp._dispatch (packages/meteorhacks_picker/packages/meteorhacks_picker.js:44:1) at processNextSubRouter (packages/meteorhacks_picker/packages/meteorhacks_picker.js:80:1) at processNextRoute (packages/meteorhacks_picker/packages/meteorhacks_picker.js:73:1) at processNextMiddleware (packages/meteorhacks_picker/packages/meteorhacks_picker.js:56:1) at [object Object].PickerImp._dispatch (packages/meteorhacks_picker/packages/meteorhacks_picker.js:50:1) at Object.Package [as handle] (packages/meteorhacks_picker/packages/meteorhacks_picker.js:140:1) at next (/opt/Bean/app/programs/server/npm/webapp/node_modules/connect/lib/proto.js:190:15) stepping down to gid: meteoruser stepping down to uid: meteoruser

I’ve removed fast-render, but I still receive the same message. Can anyone help?