Newbie trouble with basic To-Do app - "Connection closed before receiving a handshake response"


#1

I started walking through the tutorials last night and already hit a wall. I’ve search a thousand ways to find an answer to this and haven’t been able to so I must have something on my local machine causing this problem.

In the To-Do walk through I copy everything verbatim, and after I insert tasks into Mongo DB and refresh the app I get the following errors in FF and Chrome and no data from the db ever displays. I have stepped back to the basic tutorial with no DB and still see the errors. I have tried running meteor update and I have the latest version. I checked proxy settings and I have none. All firewalls are disabled.

FF - Firefox can’t establish a connection to the server at ws://localhost:3000/sockjs/354/nw_wwtce/websocket.
FF - The connection to ws://localhost:3000/sockjs/426/jb9f6yg8/websocket was interrupted while the page was loading.
Chrome - WebSocket connection to ‘ws://localhost:3000/sockjs/185/rlgmjs6b/websocket’ failed: Connection closed before receiving a handshake response
Chrome - POST http://localhost:3000/sockjs/185/ly8jm_dq/xhr_send 503 (Service Unavailable)
Chrome - WebSocket connection to ‘ws://localhost:3000/sockjs/718/g7esu9a1/websocket’ failed: WebSocket is closed before the connection is established.

Thoughts?
Thanks!


#2

Also of note, when following the tutorials none of my collection items will display even though calling db.tasks.count() tells me there are two items in there. I also moved forward and added the form to the page, it will add the item to the list but not the database. I have no proxys setup so what could be causing my machine to not allow or shut down websocket connections?


#3

I’m having the same issue. I noticed that something wasn’t right when I changed and saved the html file and the app didn’t refresh. Then, when I got to the step for adding tasks to the db, and I got stuck as well.

For the “Connection closed before receiving a handshake response” error: it refers to the line 1361 in the file simple-todos/.meteor/local/build/programs/web.browser/packages/ddp-client.js, which reads “that.ws = new Constructor(that.url);”

For the “WebSocket is closed before the connection is established” error: it refers to the line 1386 in the file simple-todos/.meteor/local/build/programs/web.browser/packages/ddp-client.js, which reads “ws.close();”

I tried removing and reinstalling meteor and creating a new test app. I’m having this issue on Chrome, FF, and Safari on OSX 10.10.1 (Yosemite).


#4

And on what OS you’re working, @ryanoutloud? Also, did you browse github issues to check if other people had similar problem and solved it already?


#5

I’m using OSX El Capitan, I’ve found a couple people post on github with the same issue but a resolution is never posted.


#6

Glad I didn’t go through the hassle of removing everything, I’ve thought about it. I’m at a stand still as I can’t move forward and I really want to use meteor on a project.


#7

Yeah, I’ve yet to find a solution on github or these forums. I’ve tried it on a few other computers (both OSX and Windows) and didn’t have any issues. Not sure what’s going on.


#8

Are you always using the same Meteor project or have you tried this with multiple projects? If you’re always using the same project, try running a meteor reset to reset the project state (warning - this will wipe your local db).


#9

I tried running meteor reset in the project directory, but it didn’t solve the issue. I’m wondering if there’s some sort of issue with the ports or something on the server’s end since it’s spitting back a 503 error code. Not sure, but at this point I’m looking into everything I can.


#10

This issue has been resolved. I was using x3watch and I didn’t realize it was sending my traffic through a proxy. Once removed everything works great. Thanks to a fellow user for the tip!!


#11

ahhhhh! This helped me tracing the error!! Thanks!