Node 0.10.40 - conflicts with Meteor pre-1.2?


#1

I noticed when I tried to deploy a new Meteor app (updated to 1.2) via mup, mup bailed with an error. I changed the Node version to 0.10.40, and it worked.

The issue is, I have a server with several Meteor apps that are pre-1.2 and need Node 0.10.36. If I deploy a Meteor 1.2 app, how will this work? Do I need to update all the other apps to 1.2 first? I don’t want mup to install Node 0.10.40 and break the existing pre-1.2 apps.


#2

I did a preliminary test on a virtual machine, and deployed a pre-1.2 app, but have Node 0.10.40 installed. It seems to work fine, but it’s just the default “click to increment” Meteor app, nothing complex. Does anyone know what the procedure should be when deploying both pre-1.2 and 1.2 apps to the same server? Is Node 0.10.40 safe for both?

PS: If Meteor 1.2 requires Node 0.10.40, that should be documented somewhere. But I’m not clear on the mup error for using Node 0.10.36, if it’s mup that needs 0.10.40 or Meteor 1.2 apps. Maybe @arunoda can weigh in?


#3

Meteor 1.2 requires node.js 0.10.40 as minimum version. I think it is pretty save to use 0.10.40 also for pre-1.2 Meteor apps since it is only a bugfix release.


#4

Yeah, pre-1.2 seemed to work ok on 0.10.40. Thanks, Sanjo!