Node-inspector buggy and out of date


#1

According to /scripts/dev-bundle-tool-package.js Meteor is using node-inspector 0.7.4. The current version is 0.12.3.

The reason this is a big deal is that node-inspector seems to be horribly broken at the moment. I can’t expand tree elements in Sources or Scope Variables. See the following GitHub issues:


According to #478, this was resolved a while ago, but is still an issue in Meteor. I tried installing node-inspector globally, but meteor debug is not using it. I’m not sure how to update/change Meteor’s version of node-inspector (I’m on Windows).

Any thoughts?


#2

So the fix in question was applied to node-inspector in December 2014:

I applied this code manually to \.meteor\packages\meteor-tool\1.1.8\mt-os.windows.x86_32\dev_bundle\lib\node_modules\node-inspector\front-end\treeoutline.js and it fixed the problem.

Is anyone else having this issue? It’s especially frustrating because debugging is broken in Webstorm as of the 1.2 release (Webstorm’s issue, not Meteor).

How would one go about updating node-inspector in Meteor? Pull request?


#3

I am having the same issue, +1 to fix that. I am a Mac user. **By now what I did to solve my issue is: **

  1. $ npm cache clean
  2. $ npm -g uninstall node-inspector
  3. $ npm install -g node-inspector --target=0.10.40

keep in mind that 0.10.40 is the node version that is showing on the console error trying to debug like:

Finally I run the inspector like:

$ env NODE_OPTIONS='--debug-brk' meteor run


SOLVED: Meteor Debug in 1.3 not logging
#4

The same issue for now. Looks like even in Meter 1.3 it still broken.

Gonna try @eterps solution.

UPD

Modification of bundled node-inspector source code was unseccesfull :slight_smile:

Solution from this SO question helped.


#5

Can confirm, node-inspector works about 1/3 of the time for me. I cross my fingers every time I press play, in hope that App running on localhost:3000 gets spit out on the console (even if it does its about ~40 seconds later.)

If changes get made and in the off chance that node inspector runs, you pretty much have to restart the whole process (for me usually some weird combo of refreshing the browser tabs / restarting meteor) to use it again.

I really don’t know if the new version of node-inspector will solve these problems, but hopefully it does. I have also have the inspector throw errors about not being able to parse source maps. (braintree specifically)