Node version for Meteor version 1.2.02


#1

Upgrading an existing app running on Ubuntu 14.04 (Digital Ocean)
I’m getting this error:
Meteor requires Node v0.10.40 or later.
I’ve been running 10.36 and thought that was the spec.
What’s the correct version of node for the latest Meteor?


#2

0.10.40 is what you should be using (Meteor 1.2 requires it). This won’t break pre-1.2 apps.


#3

Did you use mup to deploy your app?


#4

no I do mine ‘by hand’ … though I did look at the mup script to see how it does the Node install to upgrade to 10.40 … worked great.


#5

BTW, mupx is pretty solid, and I’ve switched over to use that.


#6

Is there a place in the Meteor documents or possibly in the Meteor version release documents where they state the Node version requirements? It would be nice if this were specifically called out. I know I can figure it out via trial and error, but that’s a bit cumbersome. I can’t find any official documentation online stating the Node requirements.


#7

Just run:

meteor node -v

(for now anyways - this will change in the future)