Node version for Meteor version 1.2.02

Upgrading an existing app running on Ubuntu 14.04 (Digital Ocean)
I’m getting this error:
Meteor requires Node v0.10.40 or later.
I’ve been running 10.36 and thought that was the spec.
What’s the correct version of node for the latest Meteor?

0.10.40 is what you should be using (Meteor 1.2 requires it). This won’t break pre-1.2 apps.

Did you use mup to deploy your app?

no I do mine ‘by hand’ … though I did look at the mup script to see how it does the Node install to upgrade to 10.40 … worked great.

BTW, mupx is pretty solid, and I’ve switched over to use that.

Is there a place in the Meteor documents or possibly in the Meteor version release documents where they state the Node version requirements? It would be nice if this were specifically called out. I know I can figure it out via trial and error, but that’s a bit cumbersome. I can’t find any official documentation online stating the Node requirements.

Just run:

meteor node -v

(for now anyways - this will change in the future)