[Not-Solved] Jade in local package

#1

Hi everyone.
I’m trying to use mquandelle:jade in a package structured meteor 1.4.2 application, but when I import .jade file, browser’s console spits Uncaught Error: Cannot find module './tp.jade'.
There’s a stackoverflow post that brings up a solution by changing from mquandelle:jade to waitingkuo:jade. Althought it works, I don’t like it as a solution: as soon as I tried it, an error on server’s log showed up claiming he couldn’t recognize “main” tag (HTML5’s tag). Therefore, waitingkuo:jade is a no-go for me, but I really want to use jade in my packages. Any clue on how to perform this?

#2

No one? Maybe there’s something about local packages I don’t know or don’t understand :frowning:

#3

Somehow, it managed to resolve magically :S

#4

Nope, the problem is still there :frowning: sorry for all the posts :frowning:
Now sometimes it shows Uncaught Error: Cannot find module './tp.jade' and some others Uncaught Error: Cannot find module './tp.jade.js'. I’m changing the dependencies in package.js, but I’m not sure what’s the problem.
I’ll post my files and see if someone can get to it.

/packages/app/package.js

Package.onUse(function(api) {
    api.versionsFrom('1.4.2');
    api.use('app-ui', 'client');
});

/packages/app-ui/package.js

Package.onUse(function(api) {
    const modules = [
        'ecmascript',
        'dalgard:jade'
    ];

    api.versionsFrom('1.4.2');
    api.use(modules, 'client');
    api.addFiles('main.js', 'client');
});

/packages/app-ui/main.js

import './tp.jade'

/packages/app-ui/tp.jade

head
	title App Title

Like that, I’m getting Uncaught Error: Cannot find module './tp.jade'.
If I change /packages/app-ui/tp.jade to

head
	title App Title
body 
	main Content

I get Uncaught Error: Cannot find module './tp.jade.js'

Any ideas? :S

#5

Seems like updating to meteor 1.4.2_3 solved the issue. I don’t know what to think :S