Notes on resolution of conflicts with npm packages which depend on fibers


#1

I recently ran into problems installing the npm package flightplan in my Meteor project, and want to publish my findings in case they help someone else. I believe this issue applies to using any package with a dependency on a newer version of fibers. The error appeared when running meteor:

Error: C:\Users\twastvedt\Documents\Zahner\Alfred-Zahner\az-app\node_modules\fibers\bin\win32-ia32-v8-3.14\fibers.node is missing. Try reinstalling node-fibers?

If I uninstalled flightplan everything worked fine, even though fibers was then not installed at all in node_packages.

My issue was due to flightplan having a dependency on fibers ^1.0.10 while Meteor, at the moment (as far as I can tell), needs fibers 1.0.7. It took me a while to understand what was going on, but I resolved the issue by running npm install fibers@1.0.7 --python=[path to python 2]. The --python flag is only necessary if your command line python does not default to python 2.7.