Nothing happens when running meteor bundle

Hello guys,

I have some problems with the application running meteor bundle on MacOS and Linux ubuntu.
I create bundle follows command
$ meteor build ./foldera
after that, I extracted data from bundle.tar and installed all npm modules.
And when I try run meteor app
$ METEOR_ENV=production MONGO_URL=mongodb:// ROOT_URL=http://localhost node main.js
Nothing happened. This process hangs forever.
How can I debug this case?
Meteor, node 0.10.41, MacOS 10.11.5, Ubuntu 14.04, CentOS 7.
If I running meteor app from source code, all works pretty well!


If you’re testing this locally maybe double check your ROOT_URL setting. Are you sure you want it to be “http://localhost” which means use a default port of 80? Unless you’re starting your node process as root (or a high privileged user) you won’t be able to bind to port 80 (or any port below 1024).

I have changed this setting and other ports (like 3000) and it doesn’t help me. Meteor console is empty.

I encountered the similar problem, I use export ROOT_URL=‘’, is a fake ip address. I use real ip address for my app. Then I run ‘node main.js’, but nothing happens. I can’t access my app from browser. Have you solved the problem?

Hey, yes, you need export PORT for example 3000 and configure Nginx

I have the same problem with windows, i use

ROOT_URL=http:"HTTP:\\localhost:3000" node main.js

but says

ROOT_URL=http:HTTP:\localhost:3000 : The term ‘ROOT_URL=http:HTTP:\localhost:3000’ is not recognized as the name of
a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included,
verify that the path is correct and try again.

I’ve got the same problem on macOS 10.12 with Meteor 1.5 and Node v6.11.0