Npm-bcrypt: Shared object "" not found [...] FreeBSD

Hello there, while trying to run some Meteor apps on FreeBSD I ran into the following error:


Error: Shared object “” not found, required by "bcrypt_lib.node"
at Error (native)
at Module.load (module.js:355:32)
at Function.Module._load (module.js:310:12)
at Module.require (module.js:365:17)
at require (module.js:384:17)
at bindings (/usr/local/share/meteor/.meteor/packages/npm-bcrypt/.0.7.8_2.ucabcy++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/bcrypt/node_modules/bindings/bindings.js:74:15)
at Object. (/usr/local/share/meteor/.meteor/packages/npm-bcrypt/.0.7.8_2.ucabcy++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/bcrypt/bcrypt.js:3:35)
at Module._compile (module.js:434:26)
at Object.Module._extensions…js (module.js:452:10)
at Module.load (module.js:355:32)
Exited with code: 1
Your application is crashing. Waiting for file change.

The application makes use of the accounts-password package, hence the npm-bcrypt dependency.
Does anyone know how to fix this?

I’m asking this here because there’s no GitHub repo for this package.

Hi, I am also having the same issue on FreeBSD 10.

Node version is 0.12.0.

I then tried CentOS 7 but was unable to get this working either because the Node version in the EPEL repo was 0.10.36 and it seems Meteor 1.2 requires 0.10.40.