Npm WARN saveError missing: fibers@1.0.8, required by meteor-dev-bundle@0.0.0


#1

When I deploy my app (built with METEOR@1.3.2.4) on the server (ubuntu 14.04), I get warnings like this:

npm WARN saveError missing: fibers@1.0.8, required by meteor-dev-bundle@0.0.0

How can I interpret and debug this (and is this a problem at all, because everything seems to be working)? It seems that these are not the most current versions of these packages (fibers is at available at 1.0.13).

I tried to include npm install fibers@1.0.8 --save in my deployment script but it still shows the warnings.

Any pointers appreciated.

Here is an extract of the log:

# Extract newly uploaded package
+ cd /var/www/myapp/tmp
+ tar xzf /var/www/myapp/myapp.tar.gz
+ rm -f /var/www/myapp/myapp.tar.gz
# Install dependencies
+ cd /var/www/myapp/tmp/bundle/programs/server
+ npm install password-generator --save
npm WARN saveError Problems were encountered
npm WARN saveError Please correct and try again.
npm WARN saveError missing: fibers@1.0.8, required by meteor-dev-bundle@0.0.0
npm WARN saveError missing: meteor-promise@0.5.1, required by meteor-dev-bundle@0.0.0
npm WARN saveError missing: semver@4.1.0, required by meteor-dev-bundle@0.0.0
npm WARN saveError missing: underscore@1.5.2, required by meteor-dev-bundle@0.0.0
npm WARN saveError missing: source-map-support@https://github.com/meteor/node-source-map-support/tarball/1912478769d76e5df4c365e147f25896aee6375e, required by meteor-dev-bundle@0.0.0
meteor-dev-bundle@0.0.0 /var/www/myapp/tmp/bundle/programs/server
└─┬ password-generator@2.0.2
  └─┬ optimist@0.6.1
    ├── minimist@0.0.10
    └── wordwrap@0.0.3

npm WARN meteor-dev-bundle@0.0.0 No description
npm WARN meteor-dev-bundle@0.0.0 No repository field.
npm WARN meteor-dev-bundle@0.0.0 No license field.
+ npm install --production

#2

This happens for a project I have fibers as an explicit npm dependency in my package.json. Here’s my workaround:

(cd $INSTALL_PATH/bundle/programs/server && npm remove fibers && npm install fibers@1.0.7 --save)

I reported this issue on April 6th 2016


#3

So removing before installing. Will try that. Thanks.

When I run npm list I get all the packages listed (which were listed as being missing above) - so I assume that it is okay.

├── fibers@1.0.8
├─┬ meteor-promise@0.5.1
│ └─┬ promise@7.0.4
│   └── asap@2.0.3
├─┬ password-generator@2.0.2
│ └─┬ optimist@0.6.1
│   ├── minimist@0.0.10
│   └── wordwrap@0.0.3
├── semver@4.1.0
├─┬ source-map-support@0.3.2
│ └─┬ source-map@0.1.32
│   └── amdefine@1.0.0
└── underscore@1.5.2