Obscure Error when upgrading from meteor 1.4.2 to meteor

Hi guys,

I recently tried to upgrade meteor to the newest version ( and I am encountering a very obscure error, I have been stuck for a couple of days, I just dont know what else to try. Everything was working fine when I was at 1.4.2.

This is the error:

W20170305-02:52:22.154(8)? (STDERR) TypeError: Cannot read property 'listen' of undefined
W20170305-02:52:22.154(8)? (STDERR)     at packages/shell-server/shell-server.js:70:7
W20170305-02:52:22.155(8)? (STDERR)     at ZoneDelegate.invoke (E:\web\meteor\biglup-ecommerce\apps\backoffice\node_modules\zone.js\dist\zone-node.js:232:26)
W20170305-02:52:22.156(8)? (STDERR)     at Zone.runGuarded (E:\web\meteor\biglup-ecommerce\apps\backoffice\node_modules\zone.js\dist\zone-node.js:128:47)
W20170305-02:52:22.156(8)? (STDERR)     at E:\web\meteor\biglup-ecommerce\apps\backoffice\node_modules\zone.js\dist\zone-node.js:104:29
W20170305-02:52:22.157(8)? (STDERR)     at FSReqWrap.oncomplete (fs.js:82:15)

This is how my package.json looks like:

  "name": "biglup-ecommerce",
  "private": true,
  "dependencies": {
    "@angular/http": "^2.4.1",
    "@angular/router": "^3.4.1",
    "@angular/common": "^2.1.0",
    "@angular/compiler": "^2.1.0",
    "@angular/compiler-cli": "^2.1.0",
    "@angular/core": "^2.1.0",
    "@angular/forms": "^2.1.0",
    "@angular/platform-browser": "^2.1.0",
    "@angular/platform-browser-dynamic": "^2.1.0",
    "@angular/platform-server": "^2.1.0",
    "angular2-meteor": "0.7.1",
    "angular2-meteor-polyfills": "^0.1.1",
    "babel-runtime": "^6.23.0",
    "dragula": "^3.7.1",
    "faker": "^3.1.0",
    "gm": "^1.22.0",
    "jimp": "^0.2.27",
    "lodash": "^4.16.4",
    "ng2-dragula": "^1.1.10",
    "transliteration": "^1.1.6",
    "core-js": "^2.4.0",
    "es6-shim": "^0.35.0",
    "meteor-node-stubs": "^0.2.3",
    "meteor-rxjs": "0.3.0",
    "reflect-metadata": "0.1.2",
    "rxjs": "5.0.0-beta.12",
    "zone.js": "^0.6.10"
  "devDependencies": {
    "gulp": "^3.9.1",
    "gulp-clean-css": "^2.0.12",
    "gulp-concat": "^2.6.0",
    "gulp-concat-css": "^2.3.0",
    "gulp-rename": "^1.2.2",
    "gulp-sourcemaps": "^1.6.0",
    "gulp-uglify": "^2.0.0",
    "pump": "^1.0.1",
    "run-sequence": "^1.2.2",
    "typings": "^1.3.2"

and this is how my .meteor/packaes file looks like:

meteor-base@1.0.4                # Packages every Meteor app needs to have
mobile-experience@1.0.4          # Packages for a great mobile UX
mongo@1.1.15                     # The database Meteor supports right now
reactive-var@1.0.11              # Reactive variable for tracker
jquery@1.11.10                   # Helpful client-side library
tracker@1.1.2                    # Meteor's client-side reactive programming library

standard-minifier-css@1.3.3      # CSS minifier run for production mode
standard-minifier-js@1.2.2       # JS minifier run for production mode
es5-shim@4.6.15                  # ECMAScript 5 compatibility for older browsers.

aldeed:simple-schema       # Enables use of Schemas in the app Collections
aldeed:collection2         # Child of Simple schema
konecty:mongo-counter      #

jalik:ufs                  # Custom upload file system
jalik:ufs-local            # Local implementation of custom upload file system
check@1.2.4                      #
momentjs:moment            # Date and time manipulation library
percolate:migrations       # Allows database migrations

service-configuration@1.0.11      # Allows the manipulation of 3rd party services config.

accounts-password@1.3.4          # Meteor password based account system
accounts-facebook@1.1.0          # Meteor facebook based account system
accounts-google@1.1.0            # Meteor google based account system
accounts-twitter@1.2.0           # Meteor twitter based account system


Also I have my project split into several angular2-meteor packages, in all of them I am importing angular2-compilers:


But after the upgrade something weird happend, I could no longer just import my .ts files in my packages like this:

import { Products } from '../../common/collections/product.collection';

If i dont include the .ts extension:

import { Products } from '../../common/collections/product.collection.ts';

I will get errors like this:

Error: Cannot find module '/biglup_business/common/collections/product.collection'

Since I was also lost as to why this was happening, I added the .ts extension in all the imports to see if I could get a more meaningful error, but now I am stuck at the “TypeError: Cannot read property ‘listen’ of undefined”.

Does anyone have any idea about what could the issue?


@angelcastillob Maybe you can try to update zone.js to @0.7.7 ?

Thanks @lc3t35, upgrading zone.js to 0.7.x indeed solved the issue.

1 Like