Plugin doesn't support this project's cordova-android version. cordova-android: 6.4.0, failed version requirement: >=7.0.0


#1

Hi,

I install cordova-plugin-firebase-messageing@1.1.4 in the meteor@1.7.0.5.
When I run build, it shown below.

%% Plugin doesn't support this project's cordova-android version. cordova-android: 6.4.0, failed version requirement: >=7.0.0
%% Skipping 'cordova-plugin-firebase-messaging' for android

My cordova version is 8.0.0.

I can’t find the cordova-android plugin.
Anyone have idea ?

Thank you.


#2

I find the way to upgrade the android platform version from 6.4.0 to 7.0.0.

$ cd .meteor/local/cordova-build

check your platforms version
$ cordova platforms

$ cordova plugin save
$ sudo cordova platform rm android
$ cordova platform add android

But it still shown below.

%% Plugin doesn't support this project's cordova-android version. cordova-android: 6.4.0, failed version requirement: >=7.0.0
%% Skipping 'cordova-plugin-firebase-messaging' for android

When I run the build after update android, it will execute the command.
$ rm -rf .meteor/local/cordova-build/
And the cordova-android will back to 6.4.0.
If I don’t run $ rm -rf .meteor/local/cordova-build/, build will error.
May I update the cordova-android to global environment ?

Thank you.


#3

I am not familiar how to upgrade cordova version manually. But in this case, we have to wait for Meteor to upgraded cordova to the latest version.

I hope it will be included in Meteor 1.7.2