Problem choco install meteor win10


#1

Hi all,

This is a problem about installing meteor on Windows.

I’m new to Meteor (and not very experienced in programming in general). After downloaded chocolatey i tried to install meteor using windows command prompt using “choco install meteor”. I tried many times but it looks wired. Here’s what I got:

C:\WINDOWS\system32>choco install meteor
Chocolatey v0.10.8
[Pending] Removing incomplete install for 'meteor'
Installing the following packages:
meteor
By installing you accept licenses for the packages.

meteor v0.0.2 [Approved]
meteor package files install completed. Performing other installation steps.
The package meteor wants to run 'chocolateyinstall.ps1'.
Note: If you don't run this script, the installation will fail.
Note: To confirm automatically next time, use '-y' or consider:
choco feature enable -n allowGlobalConfirmation
Do you want to run the script?([Y]es/[N]o/[P]rint): y

Extracting C:\Users\delluser\AppData\Local\Temp\chocolatey\meteor\0.0.2\meteor-bootstrap-os.windows.x86_64.tar.gz to C:\Users\delluser\AppData\Local\Temp\chocolatey\meteor\0.0.2...
C:\Users\delluser\AppData\Local\Temp\chocolatey\meteor\0.0.2
Extracting C:\Users\delluser\AppData\Local\Temp\chocolatey\meteor\0.0.2\meteor-bootstrap-os.windows.x86_64.tar to C:\Users\delluser\AppData\Local...

I run this command many many times but it seems to stop logging after this is shown.

several things i’ve tried:

1/ According to this i excluded condo.exe from windows defender but it still didn’t work.
2/tried to run command prompt as administrator and it doesn’t work either
3/I also tried using Git Bash instead of command prompt but still failed

I’m also concerned that the homepage says the current release of meteor is version 1.6.1 but the logging process shows 0.0.2. if i reinstall the whole package it still shows 0.0.2.

btw i have two users installed on this computer but i guess this doesn’t matter. As long as it works on my user account it would be fine, don’t have to install for all users

one last thing: I don’t know how to choose environment variable path. Do i need to find out the location of meteor folder, or just the location of a specific file inside this folder?

please please please … anyone know what should I do now?


EDIT: problem solved. for anyone with similar problem Just need to give it enough time for logging at this stage. :smiley:


#2

Glad it finally worked for you!

As I mention in every windows thread:

Excluding 7zip is particularly important for installs as the bundle is extracted using 7zip (7z.exe)


I stuck on downloading meteor tools on win 10!