Problem deploying with kadirahq:mup / Nginx


#1

So to keep a few hours short, I recreated the D.O. droplet which houses my apps to switch from arunoda:mupx to kadirahq:mup. I have a multiple-app environment. When I try to hit http://www.<domain>.com, I get connection refused. If I hit http://www.<domain or IP>.com:<port app is running on>, it works fine. So, it’s like proxy_pass is useless.

It’s a clean server with just nginx. Here’s an example of one of my server blocks:

server {
        listen *:80;

        server_name <DOMAIN>.com;

        location / {
        proxy_pass http://<SERVER IP>:3001/;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection 'upgrade';
        proxy_set_header X-Forwarded-For $remote_addr;
        }

}

I read something on Stack Overflow about Docker interfering with 127.0.0.1/localhost as the proxy_pass address, and it was recommended if using docker images (such as the builds hammered out by kadirahq:mup) to use the server IP. I have tried using each of these.

The only config change in nginx.conf is line 62, where I commented out include /etc/nginx/sites-enabled/*;
# include /etc/nginx/sites-enabled/*;

Here’s one of my mup.js’s:

module.exports = {
servers: {
one: {
host: ‘’,
username: ‘ryan’,
pem: “/home/ryan/.ssh/id_rsa.pem”,
opts: {
port: 47777,
},
}
},

appName: ‘’,

meteor: {
name: ‘’,
path: ‘.’,
docker: {
image: ‘abernix/meteord:base’,
},
servers: {
one: {}
},
buildOptions: {
serverOnly: true,
debug: true,
cleanAfterBuild: true,
},
env: {
ROOT_URL: ‘http://.com’,
MONGO_URL: ‘mongodb://:@162.243.31.114:27017/’,
PORT: 3001,
},

deployCheckWaitTime: 60

}
};

Here, in env:{ROOT_URL:..}, I’ve tried a few different things as well. On the old mup, I was using the server IP –
ROOT_URL : 'http://<MY IP>

Just trying a bunch of different things. Heh. Any ideas?