Problem deploying with the latest MUP

I’m using the latest version of Meteor (, the latest version of MUP (1.2.6) and node v6.10.2 but can’t get deploy to work successfully. MUP says that everything built, deployed, and started successfully but I get 502 Bad Gateway errors when connecting to my web site. Looking at MUP logs I see that there are problems downloading bcrypt during the deploy and that the app is continuously failing with the following error in mup.js:


ReferenceError: module is not defined
    at app/mup.js:1:-27
    at app/mup.js:59:4
    at /bundle/bundle/programs/server/boot.js:303:34
    at Array.forEach (native)
    at Function._.each._.forEach (/bundle/bundle/programs/server/node_modules/underscore/underscore.js:79:11)
    at /bundle/bundle/programs/server/boot.js:128:5
    at /bundle/bundle/programs/server/boot.js:352:5
    at (/bundle/bundle/programs/server/profile.js:510:12)
    at /bundle/bundle/programs/server/boot.js:351:11

The undefined “module” is in the mup.js file that MUP INIT builds: “module.exports = {”.

Any suggestions other than don’t use MUP? I’m deploying to DigitalOcean running Ubuntu 14.04 x64 vmlinuz-3.13.0-57-generic, not that it should matter.

This issue seems to have been resolved in the latest MUP build.

Lots of problems regarding this. Please use search.

I assume you mean posts not problems. None of the other posts offer a fix. Fortunately the MUP folks seem to have fixed it. But for anyone looking for the cause, module is not defined because a Meteor build for Windows was done. Setting the “–architecture os.linux.x86_64” flag to Meteor build fixes the problem.

But thanks for your help.

I really did mean problems! I’ve been watching this help section for about 3 weeks, and have seen a lot go by. Meteor 1.4 introduces a bunch of new problems. Lots of people complaining, lots of patching. But I don’t use MUP. I’m a Galaxy guy.

By the way, switch to Galaxy. It’s sooo good.

Cheers, glad you found a fix.

well, it happened with me on digital ocean … tried to increase the resources , and it worked like a charm … Hope this can help

I recommend to use PM2 for deployment.

Checkout the deployment section of the Vulcan (Meteor React boilerplate framework) docs:

Or my pm2 example config: