Problem Downloading Meteor 1.3.5_1


#1

I seem to have a problem when downloading meteor 1.3.5_1 , when trying to create a new meteor project it hangs/ gets stuck, the progress bar reaches 100% fine but then the next step just hangs there for hours and not finish. Any idea what could be the cause?


#2

What operating system are you on? Also, how much RAM and disk space do you have available?


#3

I’m using ubuntu 16.04 , 8GB ram i have 43GB free disk space.


#4

Hmm, the extraction of the meteor-tool can take some time as it’s a large tarball which extracts to almost a gig. Though, I wouldn’t expect more than about 5 minutes unless you’re on Windows which can be particularly slow at times.

Have you tried Ctrl-C’ing and trying again?


#5

I have tried doing that a couple of times and even tried when updating an already existing project, does the same thing when it gets to the downloading part…i will try to leave it to hang in that downloading state overnight and see what happens, though i have left it at that state the whole day today and still nothing gives aish.


#6

Ok, I don’t think it’s worth leaving overnight. Can you do the following for me?

  1. Ctrl-C meteor if it’s still running.
  2. Install sqlite3 on your Ubuntu 16.04 box (if you don’t have it) by running:
  • sudo apt-get install sqlite3
  1. Make a backup of your Meteor package database
    (long command, so make sure you get the whole thing):
  • cp ~/.meteor/package-metadata/v2.0.1/packages.data.db ~/.meteor/package-metadata/v2.0.1/packages.data.db.bu
  1. Run this command and see what it reports:
  • `sqlite3 ~/.meteor/package-metadata/v2.0.1/packages.data.db “vacuum”

#7

I edited my 4th command to include the full path. :wink:


#8

Cool let me do that. :sunglasses:


#9

Nothing is returned from that sqlite vacuum command


#10

Ok, that’s good! (I had you check as I’ve caught wind of a corrupted database recently, and wanted to check).

As one other test, can you run:

rm -rf ~/.meteor/package-metadata/v.2.0.1/

And then run the meteor command you were running again? This command will most likely take 10-15 minutes to run, but I’m curious if it’ll fix it for you once it finishes.

Also, if you can’t afford to spend time debugging this, the end-game here is that the tar NPM isn’t the most efficient and it’s possible that you’d be better off just re-installing Meteor – which will come with the 1.3.5.1 release already. You can just do:

curl https://install.meteor.com/ | sh

This is probably the best and quickest way to resolve your problem.


#11

.[quote=“abernix, post:10, topic:26759”]
rm -rf ~/.meteor/package-metadata/v.2.0.1/
[/quote]

Yeah i am curious to see if it fixes it, i will run it.

if i reinstall meteor what happens to my existing project that are running properly with version 1.3.3 ?


#12

if i reinstall meteor what happens to my existing project that are running properly with version 1.3.3 ?

It will still work properly, but when you run it again for the first time it will download a bundle of the 1.3.3 core code.