Problem installing meteor via npm

Im trying to install meteor on new machine (macos 11.6.2) and when i run npm install -g meteor i see : ⸨##################⸩ ⠹ reify:7zip-bin: timing reifyNode:node_modules/meteor/node_modules/semver Completed in 154ms and thats all, i have been waiting 20 mins, nothing more happened. Node version : 16.13.2 npm 8.1.2. Do you have any idea of what could be the problem?

Edit: after third retry i finally installed. But doesnt work, i checked what is installed globally and there is meteor-installer package but when i try to call use meteor zsh: command not found: meteor

Hi @schapiro, Meteor requires Node.js version >= 10 and <= 14 installed for running the npm installer. You can check other requirements here just to make sure is the only thing missing.

You can use NVM or a similar tool if you want to keep different node versions on your machine.

@fredmaiaarantes This is not the source of problems unfortunately. I tried other versions with nvm and probem is the same. I tried on other machines and problem is the same.

Can you make sure you are using the correct Node version at the moment that you try to install Meteor?

I also use MacOS, I just removed Node and Meteor from my machine and installed them all over again and just worked fine using Node 14. See the screenshot below:

Trying to replicate your issue, I removed Meteor again, installed Node 16, and tried to install Meteor. Now, I can see the same error you described. See the screenshot below:

So, I still believe the issue is the node version. If you are using NVM try to run nvm use 14 and check the current version before installing it. It should work without any issues.

i tried 12.14.1 and 14.18.3 without success. And the problem is as described in the Edit note. zsh: command not found: meteor and it is not a problem with PATH, i checked and it is proper, and other npm global packages works fine. But only thing meteor related that i see in my ~/.nvm/versions/12.14.1./bin is meteor-installer but not meteor.

You can see if it was installed by checking your ~/.meteor directory (this is where it was installed on my machine) or /usr/local/bin/meteor directory.

Another thing you could try is to use this alternative way of installing it:

curl | sh

~/.meteor director indeed exists and contains one subdir packages and no binaries. Nothing meteor related is in /user/local/bin. What is expected location of meteor binary? I thought as it installed via npm it is where other npm global packages lives, but i see on another machine it is under /usr/local/bin/meteor (installed via curl) . I know there is curl but it is not recommend as i see in docs.