Problem running Meteor after adding package "accounts-password"


#1

I am following through the book “Your First Meteor Application”. I need to run meteor using an older version so when I created the leaderboard project, I created it using:

meteor --release 1.3.2.4 create leaderboard

Everything was working really well until I got to the point when I needed to add the “accounts-password” package. I added this as follows:

meteor add accounts-password

The package adds fine but when I attempt to start meteor, I get all kinds of errors:

C:\Users\bmcderm\AppData\Local.meteor\packages\meteor-tool\1.3.2_4\mt-os.windows.x86_32\dev_bundle\server-lib\node_modules\fibers\future.js:245

Error: Could not locate the bindings file.
Tried:
C:\Users\bmcderm\AppData\Local.meteor\packages\npm-bcrypt\0.8.7_1\npm\node_modules\bcrypt\build\bcrypt_lib.node

followed by even more paths and errors

I can get back to a running state by removing the package:

meteor remove accounts-password

and then the web server will start and I can access my application.

I know this has something to do with creating my project using the --release 1.3.2.4 flag because I ran through this example before with the most recent version of meteor and did not have this problem. But, since the project I’m working on is currently constrained to this older version, I wanted to do all of my learning/prototyping using a project created with the older version.

How can I add the “accounts-password” package to this older version Meteor project?

Thank you,
Becky


#2

Here’s a little trick that worked for me.

After adding accounts-password, edit the .meteor\versions file and change the line which reads npm-bcrypt@0.8.7_1 to npm-bcrypt@0.8.6_3.

Then start meteor.


#3

Thank you so much! That solved all my problems. I really appreciate your suggestion.


#4

What kind of magic is that?