Problem with adding google maps to my project[solved]


#1

when im using - meteor npm install angular2-google-maps --save
im getting :
UNMET PEER DEPENDENCY @angular/common@2.0.0-rc.4 invalid
├── UNMET DEPENDENCY @angular/compiler@2.0.0-rc.5
├── UNMET PEER DEPENDENCY @angular/core@2.0.0-rc.4 invalid
├── UNMET DEPENDENCY @angular/platform-browser@2.0.0-rc.5
├── UNMET DEPENDENCY @angular/platform-browser-dynamic@2.0.0-rc.5
└── angular2-google-maps@0.13.0

npm WARN @angular/http@2.0.0-rc.5 requires a peer of @angular/core@^2.0.0-rc.5 but none was installed.
npm WARN @angular/http@2.0.0-rc.5 requires a peer of @angular/platform-browser@^2.0.0-rc.5 but none was installed.
npm WARN angular2-google-maps@0.13.0 requires a peer of @angular/common@2.0.0-rc.5 but none was installed.
npm WARN angular2-google-maps@0.13.0 requires a peer of @angular/compiler@2.0.0-rc.5 but none was installed.
npm WARN angular2-google-maps@0.13.0 requires a peer of @angular/core@2.0.0-rc.5 but none was installed.
npm WARN angular2-google-maps@0.13.0 requires a peer of @angular/platform-browser@2.0.0-rc.5 but none was installed.
npm WARN angular2-google-maps@0.13.0 requires a peer of @angular/platform-browser-dynamic@2.0.0-rc.5 but none was installed.

my package.json :
“dependencies”: {
"@angular/common": “2.0.0-rc.5”,
"@angular/compiler": “2.0.0-rc.5”,
"@angular/core": “2.0.0-rc.5”,
"@angular/forms": “0.3.0”,
"@angular/http": “2.0.0-rc.5”,
"@angular/platform-browser": “2.0.0-rc.5”,
"@angular/platform-browser-dynamic": “2.0.0-rc.5”,
"@angular/router": “3.0.0-alpha.8”,
“angular2-google-maps”: “^0.13.0”,
“angular2-meteor”: “0.6.2”,
“angular2-meteor-accounts-ui”: “^0.6.1”,
“angular2-meteor-auto-bootstrap”: “0.6.0”,
“angular2-meteor-polyfills”: “0.1.1”,
“angular2-meteor-tests-polyfills”: “0.0.2”,
“bcrypt”: “^0.8.7”,
“bootstrap”: “^4.0.0-alpha.3”,
“es6-shim”: “0.35.1”,
“meteor-node-stubs”: “0.2.3”,
“ng2-pagination”: “^0.3.5”,
“reflect-metadata”: “^0.1.3”,
“rxjs”: “5.0.0-beta.6”,
“zone.js”: “^0.6.12”
}

and my node version is v5.6.0
my npm version is 3.10.5

when im running my app im receiving :
Uncaught TypeError: core_1.NgModule is not a function
core_1.NgModule({ declarations: directives_const_1.GOOGLE_MAPS_DIRECTIVES, exports: directives_const_1.GOOGLE_MAPS_DIRECTIVES }), - marked red in the js console developer - chrome

thx!


#2

Can you try npm --depth Infinity update ?


#3

thank you very much!


#4

If it is solved, put [Solved] in title :wink:


#5

I’m having the same problem. Tried to update npm as you suggested, even update meteor (to 1.4.1) - no luck…