Problem with meteor run ios


I am trying to run on my IOS simulator the meteoric samples (demo, contact and meteorhunt).
XCode is installed version 6.1.1.
Everything is going fine for the demo application sample (in simulator and on my iphone).

But it does not work for the other application samples.

I get the following error:

ios: failed to start the app. ENOENT, open '/Users/houitte/SANDBOX/METEOR/METEOR_IONIC/meteorhunt/.meteor/local/cordova-build/platforms/ios/cordova/console.log'

It seems that the platforms folder in the cordova-build folder are not created.
It is strange because I did run the meteor add-platform ios.

Someone may help me ?

Thanks in advance for the help.

Best Regards,


The build process is still a little quirky. Sometimes it’s best to wipe out the Cordova build if you have weird problems.

Can you try to rm -rf .meteor/local/cordova-build and then re-run meteor run ios?

Hello Gerard,

Thanks for your help.
This is weird.
I think the ios application that is built is not the one of the current project.
There is a Xcode project in /Users/houitte/.meteor/platforms/ios called Alert1 and when I launch
run ios in the folder /Users/houitte/SANDBOX/METEOR/METEOR-IONIC/meteoric1

this is the project Alert1 that is built !!!
Maybe I have an environmental variable that is not good.

I don’t understand because it works fine for my project/Users/houitte/SANDBOX/METEOR/METEOR-IONIC/demo…

here are the logs :

I don’t know what to do.

Thanks again for your help


Even with the standard todos application, it does not work.

now instead of using the platform and plugins of the local project, meteor run ios is using platform and plugins from the home folder.

It is weird.

Strange because some days ago I managed to make work localmarket on the ios simulator and on my iphone…

Help is welcome.

Hmm. When I posted my tip earlier, I was indeed referring to your local project .meteor folder.

If that didn’t work, uou can safely wipe out the .meteor folder in your $HOME directory. You will lose everything meteor, but everything will be downloaded again.


I understood :).
I have tried everything.

  • remove $HOME/.meteor, $HOME/platforms and $HOME/plugins
  • remove meteor and reinstall it
  • remove Xcode
  • upgrade node.js
  • Create a new project meteor from the samples (todos)

when I run the following command lines:

  • meteor install-sdk ios --> ✓ Xcode is installed and ✓ Xcode license agreed
  • meteor add-platform ios --> ok
  • meteor run ios

I am getting always the following error:

ios: failed to start the app. ENOENT, open '/Users/houitte/SANDBOX/METEOR/todos/.meteor/local/cordova-build/platforms/ios/cordova/console.log'=> Started app on iOS Simulator.              => Started MongoDB.                           => Started your app.                          => App running at: http://localhost:3000/

The application Alert1 is launched in the IOS Simulator and my application todos is in the browser.

In addition, folders platforms/ios and plugins/ are created with respectively the Alert1.xcodeproj and the cordova plugins…

I don’t know what is going wrong.

Any help would be greatly appreciated.

I hope I won’t need to reinstall Mas OSX … :smile:

ps: what is weird is that it was working fine for localmarket some days ago…

Best Regards


I am pretty sure there is a problem with the script or with environment variables.


Here are the verbose logs from the command meteor run ios --verbose

Very strange behavior.

I think everything is related to an upgrade of meteor or cordova…

I would love to have my meteor dev environment working again !!!

Help please.

Best regards

Me too. My previous build gets run not the last version of my meteor app on ios. So unmeteorlike :smile:
It should just work!
Have you figured out what to do?

Hello Yann,

Thanks for your help.
After 4 days of searching (lost & depressed days !!! :slight_smile: ), I figured out that there was a config.xml cordova file in my $HOME…
That was the problem !!!


Hey man. Not lost! This will save me a lot of headache! Thanks for sharing it!

I may be late but I fix it by rm -r ~/.cordova