Problem with upgrading meteor project to 1.6


#1

I’m trying to upgrade meteor project from 1.4.3 to latest version and I’m getting an error

Funny thing is, I upgraded the same project on windows with no problems to 1.6.0.1 but then client decided to rollback to the previous version and work on something else before upgrading.
Now I’m on linux and its time to upgrade again and I can’t do it
I’m sending the log I get with the error:

0 info it worked if it ends with ok
1 verbose cli [ ‘/home/igor/.meteor/packages/meteor-tool/.1.6.0_1.obe9u1++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node’,
1 verbose cli ‘/home/igor/.meteor/packages/meteor-tool/.1.6.0_1.obe9u1++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/npm’,
1 verbose cli ‘rebuild’,
1 verbose cli ‘–update-binary’ ]
2 info using npm@5.5.1
3 info using node@v8.9.3
4 info readInstalled object
5 verbose rebuild path, id [ ‘/home/igor/.meteor/packages/meteorhacks_kadira-binary-deps/.1.5.0.1626ma4.gmm++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/.temp-1ljp4fj.8ctgj/node_modules/v8-profiler’,
5 verbose rebuild ‘v8-profiler@5.6.5’ ]
6 silly rebuild set [ ‘/home/igor/.meteor/packages/meteorhacks_kadira-binary-deps/.1.5.0.1626ma4.gmm++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/.temp-1ljp4fj.8ctgj/node_modules/v8-profiler’ ]
7 info build /home/igor/.meteor/packages/meteorhacks_kadira-binary-deps/.1.5.0.1626ma4.gmm++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/.temp-1ljp4fj.8ctgj/node_modules/v8-profiler
8 info lifecycle v8-profiler@5.6.5~preinstall: v8-profiler@5.6.5
9 verbose lifecycle v8-profiler@5.6.5~preinstall: unsafe-perm in lifecycle true
10 verbose lifecycle v8-profiler@5.6.5~preinstall: PATH: /home/igor/.meteor/packages/meteor-tool/.1.6.0_1.obe9u1++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/lib/node_modules/npm/bin/node-gyp-bin:/home/igor/.meteor/packages/meteorhacks_kadira-binary-deps/.1.5.0.1626ma4.gmm++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/.temp-1ljp4fj.8ctgj/node_modules/v8-profiler/node_modules/.bin:/home/igor/.meteor/packages/meteorhacks_kadira-binary-deps/.1.5.0.1626ma4.gmm++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/.temp-1ljp4fj.8ctgj/node_modules/.bin:/home/igor/.meteor/packages/meteorhacks_kadira-binary-deps/.1.5.0.1626ma4.gmm++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/.bin:/home/igor/.meteor/packages/meteor-tool/.1.6.0_1.obe9u1++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/bin:/home/igor/.meteor/packages/meteor-tool/.1.6.0_1.obe9u1++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/lib/node_modules/.bin:/home/igor/bin:/home/igor/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/igor/.rvm/bin:/home/igor/.rvm/bin
11 verbose lifecycle v8-profiler@5.6.5~preinstall: CWD: /home/igor/.meteor/packages/meteorhacks_kadira-binary-deps/.1.5.0.1626ma4.gmm++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/.temp-1ljp4fj.8ctgj/node_modules/v8-profiler
12 silly lifecycle v8-profiler@5.6.5~preinstall: Args: [ ‘-c’, ‘node -e ‘process.exit(0)’’ ]
13 silly lifecycle v8-profiler@5.6.5~preinstall: Returned: code: 0 signal: null
14 info linkStuff v8-profiler@5.6.5
15 silly linkStuff v8-profiler@5.6.5 has /home/igor/.meteor/packages/meteorhacks_kadira-binary-deps/.1.5.0.1626ma4.gmm++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/.temp-1ljp4fj.8ctgj/node_modules as its parent node_modules
16 verbose linkBins v8-profiler@5.6.5
17 verbose linkMans v8-profiler@5.6.5
18 verbose rebuildBundles v8-profiler@5.6.5
19 info lifecycle v8-profiler@5.6.5~install: v8-profiler@5.6.5
20 verbose lifecycle v8-profiler@5.6.5~install: unsafe-perm in lifecycle true
21 verbose lifecycle v8-profiler@5.6.5~install: PATH: /home/igor/.meteor/packages/meteor-tool/.1.6.0_1.obe9u1++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/lib/node_modules/npm/bin/node-gyp-bin:/home/igor/.meteor/packages/meteorhacks_kadira-binary-deps/.1.5.0.1626ma4.gmm++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/.temp-1ljp4fj.8ctgj/node_modules/v8-profiler/node_modules/.bin:/home/igor/.meteor/packages/meteorhacks_kadira-binary-deps/.1.5.0.1626ma4.gmm++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/.temp-1ljp4fj.8ctgj/node_modules/.bin:/home/igor/.meteor/packages/meteorhacks_kadira-binary-deps/.1.5.0.1626ma4.gmm++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/.bin:/home/igor/.meteor/packages/meteor-tool/.1.6.0_1.obe9u1++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/bin:/home/igor/.meteor/packages/meteor-tool/.1.6.0_1.obe9u1++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/lib/node_modules/.bin:/home/igor/bin:/home/igor/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/home/igor/.rvm/bin:/home/igor/.rvm/bin
22 verbose lifecycle v8-profiler@5.6.5~install: CWD: /home/igor/.meteor/packages/meteorhacks_kadira-binary-deps/.1.5.0.1626ma4.gmm++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/.temp-1ljp4fj.8ctgj/node_modules/v8-profiler
23 silly lifecycle v8-profiler@5.6.5~install: Args: [ ‘-c’, ‘node-pre-gyp install --fallback-to-build’ ]
24 silly lifecycle v8-profiler@5.6.5~install: Returned: code: 1 signal: null
25 info lifecycle v8-profiler@5.6.5~install: Failed to exec install script
26 verbose stack Error: v8-profiler@5.6.5 install: node-pre-gyp install --fallback-to-build
26 verbose stack Exit status 1
26 verbose stack at EventEmitter. (/home/igor/.meteor/packages/meteor-tool/.1.6.0_1.obe9u1++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:280:16)
26 verbose stack at emitTwo (events.js:126:13)
26 verbose stack at EventEmitter.emit (events.js:214:7)
26 verbose stack at ChildProcess. (/home/igor/.meteor/packages/meteor-tool/.1.6.0_1.obe9u1++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
26 verbose stack at emitTwo (events.js:126:13)
26 verbose stack at ChildProcess.emit (events.js:214:7)
26 verbose stack at maybeClose (internal/child_process.js:925:16)
26 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)
27 verbose pkgid v8-profiler@5.6.5
28 verbose cwd /home/igor/.meteor/packages/meteorhacks_kadira-binary-deps/.1.5.0.1626ma4.gmm++os.linux.x86_64+web.browser+web.cordova/npm/node_modules/.temp-1ljp4fj.8ctgj
29 verbose Linux 4.13.0-32-generic
30 verbose argv “/home/igor/.meteor/packages/meteor-tool/.1.6.0_1.obe9u1++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/node” “/home/igor/.meteor/packages/meteor-tool/.1.6.0_1.obe9u1++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/bin/npm” “rebuild” "–update-binary"
31 verbose node v8.9.3
32 verbose npm v5.5.1
33 error code ELIFECYCLE
34 error errno 1
35 error v8-profiler@5.6.5 install: node-pre-gyp install --fallback-to-build
35 error Exit status 1
36 error Failed at the v8-profiler@5.6.5 install script.
36 error This is probably not a problem with npm. There is likely additional logging output above.
37 verbose exit [ 1, true ]

More info:
I have Meteor 1.6.1 installed on my laptop only the project is 1.4.3, also I have latest stable versions of node and npm
I did the exact same steps I did when I was upgrading from windows 10, used ‘meteor update’, on linus i also tried with the --release flag


#2

Maybe you can try to create a new project with ‘meteor create’ just to see if your meteor installation is working fine.

Also, check https://github.com/meteor/meteor/blob/devel/History.md to be sure you don’t have breaking changes.


#3

Thanks for replying @filipenevola

Yes, I have created meteor projects on 1.6.1 and meteor is working just fine,
also I don’t believe I have breaking changes since I already updated the project once on 1.6.0.1
and I tried updating it again now at the same version thinking there might be some issues going directly to 1.6.1 but I still get the same error