Problems setting up meteor on Windows 10 64bit


#1

I tried to install meteor using the installer provided for windows.

When i run meteor create simple-todo I get the following:

events.js:141
throw er; //Unhandled ‘error’ event
^

Error write EOF
at exports._errnoException (util.js:907:11)
at WriteWrap.afterWrite (net.js:785:14)

I also tried to just start the app with : meteor, this results in the same error and nothing on localhost:3000


#2

When I run: meteor add templating@1.1.14 (Seems to be the package where it fails during meteor create)
It fails with the same error.
Seems to be a windows related problem.
Does anyone have a idea?


#3

After running meteor create simple-todo, what version does it say in .meteor/release?


#4

METEOR@1.4.1.1

I get the same result when I run meteor --version


#5

I’ll update my machine to that version and try again.
Have you tried reinstalling meteor? I had to do that on macOS for some of the more recent updates to meteor.


#6

Is that all output you get? No more logs, stack traces etc?


#7

I already tried reinstalling twice.
Also tried the alternative method provided on github (manual install)
I also tried a different computer with windows 7 64bit, exactly the same problem with the installer.

This is the only output I get in the terminal.
Is there any other place I can look for logs?


#8

Problem is SOLVED now.

I had a SDK installed for development of c programs with it’s own linux utilities.
These were also included in the windows path variable.
After removing the references the meteor create command works without a problem.

Thanks!


#9

Can you tell me what SDK that is? I’m having the same issue when I try to update meteor to a specific release.


#10

It was this SDK: http://ftp.opticon.com/C-Development/
It can be used to crosscompile apps for Opticon scanners.

This is quite a specific SDK.
I think that the general problem has something to do with linux utilities ported to Windows by another SDK or program.
They can be accessed by cmd because they are included in PATH.
The installer seems to fail before extracting so maybe a wrong tar GNU program port?
I’m just guessing…

Maybe you have somthing like:
CyWin
MinGW


#11

I found this after some more googling:

Seems indeed to be a tar related issue.
Using 7zip on windows is now planned for 1.4.2