Project run error after Meteor 2.0

There were no problems until the release of Meteor 2.0.
Since the 2.0 release, we have done a meteor update.
An error occurs when executing the project afterwards.
Of course I also ran npm update and meteor npm update commands.
But this did no problem.

In the past, when this happened, I created a new project and copied all the local files(not like package.json, .meteor). I have reinstalled all of the packages since.
It’s stupid way, but this way always worked out.
But this time it was not.

How do I fix this?

It will help if you post the actual error text here than a screenshot

That’s all errors that in the screenshot.

It looks like an incorrect connection string pass passed to MongoDB. Do you try to set MONGO_URL as an environment variable by any chance?

I also had an issue (kind of) similar to this, I think it’s your build cache messing up with your app. You should try to remove previous build under the .meteor folder (if build locally).

I solved this by formatting my pc and changing the OS from win10 to ubuntu20
I haven’t found the cause of the underlying problem.
I agree with @nschwarz’s opinion, but unfortunately it was the way I thought of it after the PC format.
Probably, when meteor is released with nodejs14, we expect to encounter this problem once again…
Then I will think about it again.
Thank you all for the answers. :slight_smile: