React-pdf/renderer vs meteor

Hi all,

trying to update my react-pdf/renderer in my meteor 2.8.0 project to the latest release (3.0.0). My react ui will not render after the update due to the error below. There’s also a post on stack overflow: reactjs - I am trying to integrate @react-pdf/renderer in my proyect and I get this error: "Uncaught TypeError: module.runSetters is not a function" - Stack Overflow

I’d really like to keep up with the latest version of the renderer, due to some memory issues in older versions.

Any ideas?

module.runSetters is not a function
    at buildCallerFunction (modules.js?hash=26231fce43d40ac065ad11db8fd1a749ed56c3e1:388592:318)
    at Object.makeCaller (modules.js?hash=26231fce43d40ac065ad11db8fd1a749ed56c3e1:388650:69)
    at BindClass.registerMethods (modules.js?hash=26231fce43d40ac065ad11db8fd1a749ed56c3e1:388386:33)
    at BindClass.registerSuperMethods (modules.js?hash=26231fce43d40ac065ad11db8fd1a749ed56c3e1:388399:15)
    at BindClass.finish (modules.js?hash=26231fce43d40ac065ad11db8fd1a749ed56c3e1:388407:71)
    at __nbind_finish (modules.js?hash=26231fce43d40ac065ad11db8fd1a749ed56c3e1:388235:40)
    at $A (modules.js?hash=26231fce43d40ac065ad11db8fd1a749ed56c3e1:395371:19)
    at _A (modules.js?hash=26231fce43d40ac065ad11db8fd1a749ed56c3e1:395309:7)
    at Object.ccallFunc [as ccall] (modules.js?hash=26231fce43d40ac065ad11db8fd1a749ed56c3e1:387407:23)
    at Object.onRuntimeInitialized (modules.js?hash=26231fce43d40ac065ad11db8fd1a749ed56c3e1:387163:16)

Ok, thanks to this thread here @react-pdf/renderer: module.runSetters is not a function · Issue #12179 · meteor/meteor · GitHub I solved it by recompiling @react-pdf/renderer by adding this to my package.json:

"meteor": {
    "mainModule": {
      "client": "client/main.jsx",
      "server": "server/main.js"
    "testModule": "tests/main.js",
    "nodeModules": {
      "recompile": {
        "@react-pdf/renderer": true

EDIT; Ok needed to remove the “Solved” tag from the title. Had it working on one dev machine locally, it did not work on a different machine and also on a staging environment on scalingo using their build system did not succeed, error on the client as in my first post here.