Release APK doesn't work as debug APK

i’ve created a app with meteor which doesn’t make use of the meteor server at all. It only communicates to private API’s. I generated my APK with ‘meteor build …/Build --server localhost:3000’
While the debug APK works as expected (I can log into my account and use the app by using a REST API), the release APK does nothing after the click on the login button (except showing that the login failed). It doesn’t even send anything to the REST API.
I tried submitting the debug app to the Play Store, but that is not possible (it says there is some information missing in the APK, which is not the case for the release APK).
Is there some dependency, which makes it impossible to deploy a true client only meteor app?
Or is there something else going on, maybe someone had the same Issues?
My guess is, that something is wrong with my build flag ‘–server localhost:3000’.
But since i never communicate to the meteor server, and this already worked fine for all debug APKs, I’m not sure about that.

Turns out that replacing localhost with fixes the issue!