[Resolved] Cannot find module 'core-js/shim'


#1

Hey, i really don’t know what to do, can you help me ?
Cannot find module ‘core-js/shim’

{
  "name": "MeteorProject",
  "private": true,
  "scripts": {
    "start": "meteor --settings settings-development.json",
    "simulation": "meteor --settings settings-development.json --production",
    "debug": "meteor debug --settings settings-development.json",
    "production": "meteor --settings settings-production.json",
    "test": "meteor test --once --driver-package dispatch:mocha",
    "chimp-test": "chimp --mocha --path=tests",
    "chimp-watch": "chimp --ddp=http://localhost:3000 --watch --mocha --path=tests"
  },
  "dependencies": {
    "babel-runtime": "^6.26.0",
    "basscss": "^8.0.3",
    "bcrypt": "^1.0.2",
    "core-js": "^2.5.1",
    "fs-extra": "^4.0.0",
    "gm": "^1.23.0",
    "i18n-react": "^0.3.0",
    "im-resize": "^2.3.2",
    "intl": "^1.2.5",
    "intl-locales-supported": "^1.0.0",
    "lodash": "^4.17.4",
    "material-ui": "^0.19.1",
    "material-ui-chip-input": "^0.17.2",
    "material-ui-superselectfield": "^1.5.6",
    "meteor-node-stubs": "^0.2.11",
    "prop-types": "^15.5.10",
    "react": "^15.6.1",
    "react-addons-css-transition-group": "^15.6.0",
    "react-cropper": "^0.12.0",
    "react-dom": "^15.6.1",
    "react-dropzone": "^3.13.4",
    "react-event-listener": "^0.5.0",
    "react-fastclick": "^3.0.2",
    "react-helmet": "^5.1.3",
    "react-html-email": "^1.2.0",
    "react-infinite-scroller": "^1.0.15",
    "react-loading": "^0.1.4",
    "react-materialui-notifications": "^0.5.1",
    "react-mounter": "^1.2.0",
    "react-notification-system": "^0.2.15",
    "react-render-html": "^0.5.0",
    "react-scroll": "^1.5.4",
    "react-string-replace": "^0.4.0",
    "react-tap-event-plugin": "^2.0.1",
    "react-touch": "^0.4.2",
    "react-transition-group": "^1.2.0",
    "simpl-schema": "^0.3.1",
    "uniforms": "^1.19.1",
    "uniforms-material": "^1.19.1"
  },
  "devDependencies": {
    "@meteorjs/eslint-config-meteor": "^1.0.5",
    "babel-eslint": "^7.2.3",
    "babel-polyfill": "^6.26.0",
    "eslint": "^4.3.0",
    "eslint-config-airbnb": "^15.1.0",
    "eslint-config-google": "^0.8.0",
    "eslint-import-resolver-meteor": "^0.4.0",
    "eslint-plugin-import": "^2.7.0",
    "eslint-plugin-jsx-a11y": "^6.0.2",
    "eslint-plugin-meteor": "^4.1.1",
    "eslint-plugin-react": "^7.1.0",
    "faker": "^4.1.0",
    "node-sass": "^3.4.2",
    "parse-json": "^3.0.0"
  }
}

and meteor package

kadira:flow-router
meteor-base
mobile-experience
mongo
blaze-html-templates
reactive-var
tracker

ecmascript
es5-shim
shell-server
accounts-base
accounts-password
react-meteor-data
email
accounts-facebook
accounts-google
service-configuration
spiderable
dynamic-import
http

#fastclick
#jquery
seba:minifiers-autoprefixer
#nathantreid:css-modules
#meteor add mixmax:smart-disconnect // for disconnect inactive user
#bundle-visualizer
#meteorhacks:fast-render

themeteorchef:bert
planettraining:material-design-icons-font
fourseven:scss
ostrio:files
#underscore
momentjs:moment

percolate:migrations
aldeed:schema-deny

tap:i18n
softwarerero:accounts-t9n

tmeasday:publish-counts
reywood:publish-composite
peerlibrary:reactive-publish

aldeed:collection2-core
dburles:collection-helpers
matb33:collection-hooks

check
mdg:validated-method
alanning:roles

abernix:standard-minifier-js
#juliancwirko:postcss
ddp-rate-limiter

dburles:factory
xolvio:backdoor
xolvio:cleaner
johanbrook:publication-collector
practicalmeteor:chai
practicalmeteor:sinon
practicalmeteor:mocha
hwillson:stub-collections
session

Hope someone can help me, im facing this after the last meteor update !


#2

Ok my bad ! , some code with import 'babel-polyfill will make this error