[ RESOLVED ] Deploy on a specific organization in galaxy // transfert app between organizations

My meteor user is part of two organization. How do I specify the one I want to deploy for ?

[ EDIT 2 ]

hwillson gave the answer :

DEPLOY_HOSTNAME=galaxy.meteor.com meteor deploy [hostname] --owner [organization_name] --settings path-to-settings.json

If you went wrong, the previous solution still works.

[ EDIT ]

I could not find how I can (meteor CLI should ask which organization we want to deploy to, not randomly send to some of the organization you belong to)

The solution is to deploy, go see where it lands, and then :

DEPLOY_HOSTNAME=galaxy.meteor.com meteor authorized applicationHostName --transfer organizationName

Maybe, I don’t want the random organization it will deploy to at first to see my settings.json with my mongo, s3, stripe and mailgun keys…

3 Likes

Check out the “Transferring an app to another account” section of the Galaxy Help Center:

You can deploy an application to one Galaxy account at a time.

Galaxy utilizes the following policy to select the account to deploy your app to:

  • If an application with the specified hostname already exists in an account, Galaxy deploys to the same account.
  • If it is a new application, Galaxy chooses the individual user account if it exists.
  • If it is a new application, and individual user account does not exist, Galaxy chooses the first Galaxy organization account that you are a member of.

If you are a member of two or more accounts, you can then transfer the application to a different account.

To transfer the application, on the command line, type: DEPLOY_HOSTNAME=galaxy.meteor.com meteor authorized [your_existing_hostname] --add [new_account_name]

You need to have deploy privileges to the account new_account_name.

1 Like

I’m in an organizationA with a deployed app : appA ; And in an organization B with no deployed app. When I try to deploy the app appB of the organizationB, it deploys in the organization A account.

The applicationB is deployed like that :

DEPLOY_HOSTNAME=galaxy.meteor.com meteor deploy appB.meteorapp.com --settings=settings-prod.json

So I tried :

DEPLOY_HOSTNAME=galaxy.meteor.com meteor authorized appB.meteorapp.com --add organizationB

And I got :

Couldn't change authorized users: Cannot add owners via --add.

What did I miss ?

My guess is something related to “You need to have deploy privileges to the account new_account_name.”. Maybe give Galaxy support a shout.

I edited with the solution.

1 Like

I belong to 3 organizations. The last organization still has 4 containers available while the other organizations has no container left. When I tried to deploy, I got this error:

Error deploying application: Your account container limit has been reached.

However, I couldn’t choose which organization to deploy to.

With the latest version release of Meteor 1.3, you can specify at deploy time which account to deploy to from the Meteor CLI:

DEPLOY_HOSTNAME=galaxy.meteor.com meteor deploy [hostname] --owner [target_account_name] --settings path-to-settings.json

With prior version releases of Meteor (before 1.3), you will need to deploy and then transfer to an account:

DEPLOY_HOSTNAME=galaxy.meteor.com meteor authorized [your_existing_hostname] --add target_account_name

1 Like

Small addition to @rohit2b’s explanation - if you’re deploying to an organization (team) you’re part of, make sure you use the organization name as the owner:

DEPLOY_HOSTNAME=galaxy.meteor.com meteor deploy [hostname] --owner [organization_name] 
--settings path-to-settings.json
2 Likes

Thanks you :slight_smile:

I edit my answer.

I tried following these instructions but nothing worked.

Organization 1 with User A and User B as members. Deployed app to User A's personal account and then transferred to Org 1.

User A is still able to deploy new versions to Org 1. But User B always receives:

Error deploying application: This domain is already in use on Galaxy.

I’ve tried using --owner Org1, --owner UserA, --owner UserB, and no --owner at all but results are always the same.

2 Likes

Works great @hwillson
Thanks

did you solve this? I get same problem
domainName: This domain is already in use on Galaxy.

Our app was deployed to www.blackship.com
but we are moving it to blackship.whiterabbitexpress.com
so I added the new domain but I get this error when I try to deploy to the new domain