[RESOLVED] Login Button in Tutorial not working


#1

Seem like the {{> loginButtons}} in the tutorial is not working, the whole page gone blank. Anyone can light me up?

Below are the code i am using,


simple-todos.html
simple-todos.js

I am using Windows client.


#2

Hit F12, paste your console here.


#3

myapp.js:76 Uncaught ReferenceError: Accounts is not defined
blaze.js:2979 Uncaught Error: No such template: loginButtons
http://localhost:3000/favicon.ico Failed to load resource: the server responded with a status of 404 (Not Found)

Thanks


#4

check you have the accounts-ui package installed under .meteor\package, do a meteor update in your root project folder and try again.
It’s not loading your Accounts package for some reason. If you just cloned the project you linked to it should be ok…


#5

The .meteor\packages and the meteor update only provide below three packages,

meteor-platform
autopublish
insecure

i added below packages and it works.

meteor add accounts-ui
meteor add accounts-password 

(other turnkey interface added as well, accounts-facebook, accounts-github,
accounts-google, accounts-twitter, or accounts-weibo)

Many thanks for your help :+1:


#6

Interesting, but the repo you linked to has the packages you were missing: https://github.com/meteor/simple-todos/blob/master/.meteor/packages
So at some point, something must have happened to cause some issue!


#7

@ahshang: Did you git clone the repo or just copy/paste the code?


#8

I was following below tutorial and just copy & paste, didn’t did git clone.
https://www.meteor.com/tutorials/blaze/creating-an-app


#9

I don’t think meteor’s password validation likes mixed case. Once i changed to lower case only password and deployment worked as well as the ability to log into this form. What was a little strange was that my mixed case password worked for logging into meteor. Makes me question the account validation package being used.