[RESOLVED] Meteor 1.2 : "ReferenceError: Router is not defined"

i just updated from 0.9 to 1.2 and i got an error trying to build my app…
Here is the error:

W20151024-12:07:50.650(3)? (STDERR)           
W20151024-12:07:50.650(3)? (STDERR) /home/slade/.meteor/packages/meteor-tool/.1.1.9.ltydx3++os.linux.x86_64+web.browser+web.cordova/mt-os.linux.x86_64/dev_bundle/server-lib/node_modules/fibers/future.js:245
W20151024-12:07:50.650(3)? (STDERR) 						throw(ex);
W20151024-12:07:50.650(3)? (STDERR) 						      ^
W20151024-12:07:50.663(3)? (STDERR) ReferenceError: Router is not defined
W20151024-12:07:50.664(3)? (STDERR)     at lib/config.js:6:1
W20151024-12:07:50.664(3)? (STDERR)     at ­­~/.meteor/local/build/programs/server/app/lib/config.js:9:4

the code is the following:

   layoutTemplate: 'layout' 

i tried to do meteor add iron-router (even if it’s supposed to be there) but meteor reply:

 => Errors while parsing arguments:           
While adding package iron-router:
error: no such package

I was using iron-router before the update without problem. I tried to google but no solutions find. If somebody have some idea it will be greatly appreciated :smile:
Thanks :smile:

Have you checked if iron:router is installed?

I tried to install it but meteor couldn’t locate the package… But i fixed it somehow…
By doing a meteor search router | grep iron
then, firing meteor add iron:router this time works… When it was failed earlier… I have no idea what happened.

1 Like

By the way, I would recommend using Flow Router :slight_smile:

1 Like

i’ll check it out :wink:

I already had iron router installed but somehow running meteor add iron:router worked for me too