[RESOLVED] 'PlayersList.insert' is not recognized as a command


#1

Hey I just started learning Meteor today and been following this tutorial. Upon trying to insert data into the collection through the command line with PlayersList.insert(); I get a message saying 'PlayersList.insert' is not recognised as an internal or external command, operable program or batch file.

When I googled I found a similar issue of the happening to people with the meteor command. I followed what worked for them and made sure I had the correct path set(C:\Users\UserName\AppData\Local.meteor) and I do both in system and user, although it wouldn’t make sense for it to be the same problem since I’ve been anle to use the meteor command so far.

Any ideas? It’d be great if I can solve this soon, I’d hate to waste the day with something stupid like this.

EDIT: Using Windows 8.1


#2

You need to run that in the Javscript console of your browser not on the terminal of your machine.


#3

I tried that thinking it may render a different result, but I got the same exact message.


#4

I’m sorry wasn’t the same message, it says…

Uncaught Error: insert requires an argument
    at Mongo.Collection.(anonymous function) [as insert] (http://localhost:3000/packages/mongo.js?3cfe0c5981c197df33036a37574850f057e934a6:560:15)
    at <anonymous>:2:13
    at Object.InjectedScript._evaluateOn (<anonymous>:905:140)
    at Object.InjectedScript._evaluateAndWrap (<anonymous>:838:34)
    at Object.InjectedScript.evaluate (<anonymous>:694:21)

#5

GAhhhh sorry guys I’m an idiot…needed to inser an argument, AKA a string in the parenthesis. New to this lingo face palm