Revisiting old meteor projects


#1

I’m not sure whether this is a common problem, but I’m practically unable to run meteor apps that are about a month old. I took a break from a project and now when that I’m getting back to it, I’m unable to meteor run. I get a myriad of errors which force exit. I haven’t changed a single thing in the project. This has happened more than once.

I wish I could replicate the errors here but I’ve lost track of them and now, that particular project is stuck at extracting meteor-tool. So I’ve just created a new project and moved files over rather than spend hours trying to sort this.

I just wanted to know if this is unique to me, or if it’s a common Meteor problem. Cause it’s kind of putting me off to Meteor tbh.


#2

If we don’t know the errors we can’t help you. No. I updated a 1 year old Meteor app, from 1.2.x to 1.4.2 without any change in the code, it worked smooth as butter. Quite amazed actually.


#3

If I manage to replicate the error, I’ll post it here.

What OS do you run on? I’m on Windows and I’ve had numerous annoying experiences while running Meteor on my machine. Maybe it’s my computer that has some conflicts with Meteor.


#4

Meteor is trying to download the latest build tool. However, you can avoid this by pinning your meteor run command to the version of your project. For example

meteor --release 1.2.1 run

You can find the version of Meteor your project is using by looking in .meteor/release.


#5

Blimey. It actually worked! Thanks