Run android cannot find Sdk, but build can

I have a strange problem here, if I run meteor run android (or run android-device) i obtain this error:

Your system does not yet seem to fulfill all requirements to build apps for Android.
Please follow the installation instructions in the mobile guide:
Status of the individual requirements:        
✓ Java JDK                                    
✓ Android SDK                                 
✗ Android target: Android SDK not found. Make sure that it is installed. If it is not at the default location, set the ANDROID_HOME
  environment variable.
✓ Gradle      

Obviously I have installed android v24, v25.2 and v26 SDK and the $ANDROID_HOME variable is ok!

The strange thing is that if I run:
meteor build ../builddire --settings settings.json --mobile-server
the package build correctly and I obtain my unsigned-release.apk (that could not be build without Sdk…)

Do you have any advice to get this working? Thank you everyone!

Could you tell us the exact file path for your SDK installation?