Sass filepath is failing on CI build


#1

I’m trying to deploy my app on CodeShip to meteor.com servers and it fails when building the app… However it builds fine on my local machine.

Any ideas on why this would break? I’ve upgraded to fourseven:scss@3.1.1 (running Meteor 1.1.0.2) and that gave me a better error. For some reason the paths are not working once it’s being built… any work arounds?

The main.scss file is in client/styles/main.scss.

npm-container: updating npm dependencies -- externalify, dedent, alt,
iso-3166-2, react-datepicker, redux, react-redux, redux-devtools...
Deploying to foobar.meteor.com.

Errors prevented deploying:
While building the application:

/home/rof/src/github.com/foobar/foo-app/client/styles/_components.scss:2:9:
Scss compiler error: file to import not found or unreadable:
../../both/components/footer/Footer
Current dir: /home/rof/src/github.com/foobar/foo-app/client/styles/

#2

there is also v3.2.0 for Meteor 1.1.* maybe this one will help …


#3

Thanks for the help @juliancwirko ! I was wondering what the newest was workable ver was. I updated to this and pushed but it still has the same error :confused:


#4

I’ve gotten a bit further, this issue mentions a problem deploying to Heroku and a buildpack fixes it but I don’t understand exactly what this buildpack is doing to get around this issue…

https://github.com/AdmitHub/meteor-buildpack-horse/blob/fb37ee8c099dbd8113c8dba2fe0a72707ca2c4f8/bin/compile#L79


#5

Still no headway. I guess the moral of the story is to use the least amount of Meteor packages as possible to maintain a stable app :frowning:


#6

and the only fourseven:scss package which works well with Meteor 1.2 is beta version :wink: (for now) Scss with Meteor is hard :wink: